Closed Bug 1362918 Opened 3 years ago Closed 3 years ago

Extend the blacklist of disabling adaptive playback feature for some specific Galaxy S4 model

Categories

(Firefox for Android :: Audio/Video, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 55
Tracking Status
firefox53 + wontfix
firefox54 + fixed
firefox55 + fixed

People

(Reporter: JamesCheng, Assigned: JamesCheng)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

For bug 1360626, comment 37 and comment 38... we need to extend the blacklist range to cover those two models.

Hope it works.
Comment on attachment 8865304 [details]
Bug 1362918 - Extend the blacklist to cover certain Galaxy S4 models.

https://reviewboard.mozilla.org/r/136946/#review139908
Attachment #8865304 - Flags: review?(jolin) → review+
Duplicate of this bug: 1362921
Hi Jens and clgillum,

Would you please help me to check if this apk works on your S4 devices?

https://queue.taskcluster.net/v1/task/X5jm3iM0RNKKE447EWDXTA/runs/0/artifacts/public/build/target.apk

If so, I will check in the code and request uplifting.

Thanks.
Flags: needinfo?(jens.vehreschild)
Flags: needinfo?(clgillum)
That didn't fix it.  Youtube videos are still playing with horizontal slices that are out of order and only in gray.  They play through the default browser correctly.  This started about a week ago.  Is this the same bug symptoms as S3 or something else?  Would a screen capture of the playback be useful?
Flags: needinfo?(clgillum)
If the symptom is similar to https://bugzilla.mozilla.org/attachment.cgi?id=8862934&action=edit

I think they are the same root cause.

But I do add the model you provided into blacklist...

Could you please let me know how you get the model ID and could you please delete the current app and reinstall from https://queue.taskcluster.net/v1/task/X5jm3iM0RNKKE447EWDXTA/runs/0/artifacts/public/build/target.apk
and test it again(please give me the screen shot if possible)?

Thanks
Flags: needinfo?(clgillum)
From the duplicate bug, sounds like 53 and up are affected. 
Kevin, were you able to reproduce this? 
Or, Ioana, does your team have this hardware for testing?
Flags: needinfo?(kbrosnan)
Flags: needinfo?(ioana.bugs)
I don't believe either of us have hardware. Affected users from comment 0 of the duped bug are our best bet.
Flags: needinfo?(kbrosnan)
Fine with me, apk working. videos ok.
Flags: needinfo?(jens.vehreschild)
Hi clgillum,

Since the apk works fine for Jens, could you please use below apk to test again and provide me the log from adb logcat which I dump the ModelId.

Maybe you can grep 'GeckoHardwareCodecCapabilityUtils: ModelID'.

https://queue.taskcluster.net/v1/task/Rlnf-YM6SjCfZjz6qZH1fA/runs/0/artifacts/public/build/target.apk

Thanks.
Flags: needinfo?(clgillum)
Hi clgillum,

I saw your screenshot and I suspect that the model ID I listed to blacklist is not the same with the API Build.MODEL returns.

The screenshot shows "SEPF_SGH-M919" and if Build.MODEL prints the same string, I will modify the blacklist.

Please see comment 10 and give me some clue,

Thank you!
Flags: needinfo?(clgillum)
I have the same bug on my S4 SGH-I337 Android 4.4.2 with the last version 53.0.2
(In reply to John from comment #12)
> I have the same bug on my S4 SGH-I337 Android 4.4.2 with the last version
> 53.0.2
Hi John, 
Would you please also provide me the log with model Id string as comment 10 said.

I will add the string into blacklist

Thanks
Flags: needinfo?(juanjotoronja)
Hi clgillum,

This apk just add the SEPF_SGH-M919 into blacklist.

Hope it works on your device, 

Please also test this apk.

Many thanks.


https://queue.taskcluster.net/v1/task/O5UlEv_PSt2nBTq_ElQWNQ/runs/0/artifacts/public/build/target.apk
I don't know how to get the log from adb logcat, but after reading the specs from SGH-M919 and SGH-I337 at https://en.wikipedia.org/wiki/Samsung_Galaxy_S4#Model_variants they have the same hardware, I can test the apk from comment 10 if you want.
Flags: needinfo?(juanjotoronja)
(In reply to John from comment #15)
> I don't know how to get the log from adb logcat, but after reading the specs
> from SGH-M919 and SGH-I337 at
> https://en.wikipedia.org/wiki/Samsung_Galaxy_S4#Model_variants they have the
> same hardware, I can test the apk from comment 10 if you want.
Hi John,

It will be good if you know how to get the log.

I add the SGH-I337 into blacklist and please use below apk to test if it works.

https://queue.taskcluster.net/v1/task/Q_Ju82N3SQWPnR1GrO1RgQ/runs/0/artifacts/public/build/target.apk

Thanks.
Flags: needinfo?(juanjotoronja)
Hi James,

You need the full log file or only a screenshot from the model Id string?
Flags: needinfo?(juanjotoronja)
OK James,

I've tested the apk from comment 10 and the video bug was still there, here is the string:

GeckoHardwareCodecCapabilityUtils,Nightly,ModelID = SAMSUNG-SGH-I337

Also tested the apk from comment 17 and video was fixed, let me know if you still need the log file.
Hi John,

Thank you so much that you provides the ModelId from log, that's enough :),

Glad to hear that the root cause is the same as S3 case.

I've added it to the blacklist in this patch.

I'm waiting for clgillum's feedback to see if I can do more.

Thanks.
Look again the impl in google

https://cs.chromium.org/chromium/src/media/base/android/java/src/org/chromium/media/MediaCodecUtil.java?ssfr=1&type=cs&q=isAdaptivePlaybackBlacklisted&l=421

They only think the issue happened on 4.4.2.

But for clgillum's device, it's 4.4.4, so I remove this check to see if it works

Hi clgillum,

Please use this apk to check if it is fixed.

https://queue.taskcluster.net/v1/task/fekKcg0BTQu2_gbxQZvMlA/runs/0/artifacts/public/build/target.apk

Thank you
Flags: needinfo?(clgillum)
Please see comment 22. Thanks.
Flags: needinfo?(clgillum)
That worked!  Thanks James
Flags: needinfo?(clgillum)
Pushed by jacheng@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0398b6fa1a0e
Extend the blacklist to cover certain Galaxy S4 models. r=jolin
Comment on attachment 8865304 [details]
Bug 1362918 - Extend the blacklist to cover certain Galaxy S4 models.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1317239
[User impact if declined]: Video corruption on some devices
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: No
[Needs manual test from QE? If yes, steps to reproduce]: Would be helpful. Simply play a video on an affected device such as a Galaxy S4.
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: It only disables a feature that was only recently added on a subset of devices.
[String changes made/needed]: None
Attachment #8865304 - Flags: approval-mozilla-release?
Attachment #8865304 - Flags: approval-mozilla-beta?
Attachment #8865304 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/0398b6fa1a0e
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Hi Ioana,
Do you have a Galaxy S4 device to verify this issue?
Flags: needinfo?(ioana.chiorean)
Also NI Mihai to support verifying the issue.
Flags: needinfo?(mihai.ninu)
From comment 8 above, no one from QE at Mozilla has the hardware. 
We can ask the users who reported the issue on SUMO 
(https://support.mozilla.org/en-US/questions/1159073, https://support.mozilla.org/en-US/questions/1158437)
Jens, clgillum, if you can try the latest Nightly on your S4 devices to see if you can verify that it's fixed, and comment here, that would be super helpful.   If someone can verify in the next day or so, I'm ok with bringing this fix to 53.
Flags: needinfo?(jens.vehreschild)
Flags: needinfo?(clgillum)
Hi Liz, 
https://queue.taskcluster.net/v1/task/fekKcg0BTQu2_gbxQZvMlA/runs/0/artifacts/public/build/target.apk 
-fixed the issue here.
Flags: needinfo?(jens.vehreschild)
Oh..., sorry Liz. The LATEST nightly. -Issue fixed on my device.
Thank you Jens!   I think we can probably bring this fix to 54.
Flags: needinfo?(mihai.ninu)
Flags: needinfo?(ioana.chiorean)
Flags: needinfo?(ioana.bugs)
Comment on attachment 8865304 [details]
Bug 1362918 - Extend the blacklist to cover certain Galaxy S4 models.

Let's uplift to beta so this will be in place for the 54 release. 
We don't need aurora uplift anymore because of the Dawn project. 

So far, I don't think this is a widespread enough problem to justify shipping a dot release to fix it.
Attachment #8865304 - Flags: approval-mozilla-beta?
Attachment #8865304 - Flags: approval-mozilla-beta+
Attachment #8865304 - Flags: approval-mozilla-aurora?
Attachment #8865304 - Flags: approval-mozilla-aurora-
At this point I'm not expecting any further 53 releases.
Attachment #8865304 - Flags: approval-mozilla-release? → approval-mozilla-release-
Flags: needinfo?(clgillum)
You need to log in before you can comment on or make changes to this bug.