Parallel builds in ldapcsdk failing because of race condition in dist

RESOLVED FIXED

Status

Directory
LDAP C SDK
--
major
RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: Donnie Cranford, Assigned: dmose)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
dmose asked me to file a bug on him for this problem...

Steps to reproduce 

1. in your .mozconfig have a MOZ_MAKE_FLAGS=-j4 or higher
2. run gmake -f client.mk build


Actual Result :
gmake[5]: Entering directory `/export/home/mozilla/directory/c-sdk/ldap/include'
../../config/./nsinstall -D /export/home/mozilla/dist/public/ldap
perl ./../build/replace.pl \
        LDAP_VENDOR_NAME="mozilla.org" \
                LDAP_VENDOR_VERSION="500" \
                < ldap-standard-tmpl.h >
/export/home/mozilla/dist/public/ldap/ldap-standard.h
/bin/sh: /export/home/mozilla/dist/public/ldap/ldap-standard.h: cannot create
gmake[5]: *** [/export/home/mozilla/dist/public/ldap/ldap-standard.h] Error 1


Expected Result :
Continue compiling in parallel

----------------------------------------------------------------

just for public knowledge this has been confirmed on Solaris 8 and Solaris 9

using gmake 3.79.1


Thanks

-dcran-
(Reporter)

Comment 1

16 years ago
making dmose the owner

Assignee: mcs → dmose
QA Contact: nobody → dmose
Summary: Parallel builds in ldapcsdk failing because of race condition in dist → Parallel builds in ldapcsdk failing because of race condition in dist
(Assignee)

Comment 2

16 years ago
Need to create $(DIST) if it doesn't already exist before running the script.
Status: NEW → ASSIGNED
(Reporter)

Comment 3

16 years ago
Created attachment 78295 [details] [diff] [review]
patch as suggested by Dauphin
(Reporter)

Updated

16 years ago
Attachment #78295 - Attachment is obsolete: true
(Reporter)

Comment 4

16 years ago
Created attachment 78296 [details] [diff] [review]
patch as stated by Dauphin
(Reporter)

Comment 5

16 years ago
i have tested this patch and verified it works, lets go 

r=dcran, just needs sr= and a=
(Assignee)

Updated

16 years ago
Attachment #78296 - Flags: review+
(Assignee)

Comment 6

16 years ago
Comment on attachment 78296 [details] [diff] [review]
patch as stated by Dauphin

r=dmose

Comment 7

16 years ago
Comment on attachment 78296 [details] [diff] [review]
patch as stated by Dauphin

a=asa (on behalf of drivers) for checkin to the 1.0 branch
Attachment #78296 - Flags: approval+
Patch has been checked into the moz1.0 branch and the ldap50client branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.