Closed Bug 1363030 Opened 3 years ago Closed 3 years ago

When using a proxy suddenly Firefox is unable to load pages

Categories

(Core :: Networking: HTTP, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1360574
Tracking Status
firefox-esr52 --- unaffected
firefox53 --- fixed
firefox54 --- fixed
firefox55 --- fixed

People

(Reporter: underpass_bugzilla, Unassigned)

Details

(Keywords: regression)

Approximately once every hour I am forced to restart the browser over again as it suddenly can't load any website.
The problem has happened the first time upon upgrading from 53b10 to 53RC1 and has not been solved ever since. My PC is connected to the Internet via a McAfee Web Gateway proxy, version 7.6.2.6.0.22529 that I cannot upgrade, stop, restart or reconfigure.

Beyond the usual troubleshooting steps I've tried to create a new profile, to use the stable release, to use the Nightly release, to change several parameters via about:config (for example change http version, disable spdy, disable http2, disable prefetch, disable IPV6, configure keep-alive) with no success. This condition is true also on other PCs of the network.
The problem doesn't happen on PCs with direct connection to the Internet.

Don't know which changes have been made between version 53b10 and 53RC1 but I fear that one of then is the cause of this problem.
I can provide verbose Firefox log if required.

Thanks for your attention.
Component: General → Networking: HTTP
Product: Firefox → Core
The user Philipp (thanks!) who answered me in this thread

https://support.mozilla.org/it/questions/1159240

pointed me to this bug related to proxy connections

https://bugzilla.mozilla.org/show_bug.cgi?id=1348841
Keywords: regression
What if you upgrade to 53.0.2 release?  Or, if you are on the beta channel, to 54 beta? Because it sounds like we may have fixed this just before 53 release.  If not, it would definitely be good to know!
Flags: needinfo?(underpass_bugzilla)
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #2)
> What if you upgrade to 53.0.2 release?  Or, if you are on the beta channel,
> to 54 beta? Because it sounds like we may have fixed this just before 53
> release.  If not, it would definitely be good to know!

The problem is verified on *every* version beyond 53b10: tried on stable, beta and Nightly versions.
We are using  proxy server at our organization.

We use browsers Firefox, Chrome, IE. Chrome, IE and Firefox 52 - work fine and proxy works nice for them.

After update Firefox to last version (53.0.2) - have problems, browser after 30 minutes (or more), does not open or refresh pages. Just blankpage and refresh icon at tabs. If close and open browser, problem repeat after 30 minutes.
The problem has described in this bug articles   Bug 1360574  and Bug 1363030 .

FF version (53.0.2) doesn't reset value of network.http.connections after tabs closed  (open sites):

http://my.jetscreenshot.com/demo/20170511-3ckm-35kb

And after the value reaches "network.http.max-connections=900"  Firefox stops working.

The problem doesn't happen on PCs with direct connection to the Internet.

Increasing "network.http.max-connections" does not seem to be a solution,  even temporary.

We need help, because this affects a many of users.

Thanks for your attention.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1360574
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #2)
> What if you upgrade to 53.0.2 release?  Or, if you are on the beta channel,
> to 54 beta? Because it sounds like we may have fixed this just before 53
> release.  If not, it would definitely be good to know!

Sorry Liz, could you or anyone clear the "needinfo" flag? I don't seem to have the necessary rights.
Thanks.
You need to log in before you can comment on or make changes to this bug.