a:visited colors are not correctly being applied in 53.0.2

RESOLVED DUPLICATE of bug 713106

Status

()

Firefox
Developer Tools: Inspector
RESOLVED DUPLICATE of bug 713106
a year ago
a year ago

People

(Reporter: simbalion-github, Unassigned)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8865531 [details]
firefox bug screenshot.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170504175505

Steps to reproduce:

Loaded a webpage with links I had visited. 


Actual results:

The :visited links are showing as black but they should be blue. I opened the dev console and confirmed that the blue color is what the dev console thinks is active.


Expected results:

The links should have been blue, instead they were black.

Please see the attached screenshot for proof.
(Reporter)

Updated

a year ago
Summary: a:visited colors are not correctly being applied in 53.0.2 (64-bit) → a:visited colors are not correctly being applied in 53.0.2 (64-bit) (Linux)
(Reporter)

Updated

a year ago
OS: Unspecified → Linux
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core
Looks fine on macOS. A graphics issue maybe.
Component: CSS Parsing and Computation → Graphics: Text
Sorry, I could reproduce the issue on macOS as well. Moving back to the CSS component.
Component: Graphics: Text → CSS Parsing and Computation
OS: Linux → Unspecified
Summary: a:visited colors are not correctly being applied in 53.0.2 (64-bit) (Linux) → a:visited colors are not correctly being applied in 53.0.2
This seems like a mistake in the site's CSS.

Looking at the style.css file, we have:

Line 102:

a, a:visited {
  text-decoration: none;
  color: #007fd5; }

Line 849:

.prices a, a:visited {
  color: initial;
  }

Since both rules use the selector `a:visited`, the last value for `color` is used, which is `initial`.

So, the CSS is applied correctly, but it's quite hard to tell from the inspector because visited styles currently aren't displayed there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Component: CSS Parsing and Computation → Developer Tools: Inspector
Product: Core → Firefox
Resolution: --- → DUPLICATE
Duplicate of bug: 713106
(Reporter)

Comment 4

a year ago
(In reply to J. Ryan Stinnett [:jryans] (use ni?) from comment #3)
> This seems like a mistake in the site's CSS.
> 
> Looking at the style.css file, we have:
> 
> Line 102:
> 
> a, a:visited {
>   text-decoration: none;
>   color: #007fd5; }
> 
> Line 849:
> 
> .prices a, a:visited {
>   color: initial;
>   }
> 
> Since both rules use the selector `a:visited`, the last value for `color` is
> used, which is `initial`.
> 
> So, the CSS is applied correctly, but it's quite hard to tell from the
> inspector because visited styles currently aren't displayed there.

You're right, this is a mistake in the CSS, it should be .prices a, .prices a:visited. I appreciate you pointing that out, however the inspector shows the code being applied is style.css:102 rather than style.css:849.. Shouldn't line 102's color line be crossed out and line 849s be visible?

If I understand your comment completely, :visited is ignored by the inspector regardless of the circumstances? If I were to replicate the offending typo in other ways like ".class element, element:visited" will that always hide the line from the inspector?

Comment 5

a year ago
(In reply to simbalion-github from comment #4)

> If I understand your comment completely, :visited is ignored by the
> inspector regardless of the circumstances? If I were to replicate the
> offending typo in other ways like ".class element, element:visited" will
> that always hide the line from the inspector?

Yes.  The basic problem is that there's no way for the inspector to ask platform to
show visited styles.  For details see the bug this was dup'd to, and its dependencies.
You need to log in before you can comment on or make changes to this bug.