Closed Bug 136324 Opened 18 years ago Closed 15 years ago

Javascript infinite loop

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 61098

People

(Reporter: ahde, Assigned: rogerl)

Details

I discovered, while trying a simple javascript, that it is quite easy to create
an infinite loop of popups -- a porn site designer's wet dream.  

This may just be a usability issue, but I don't recommend forcing the user to
endure it.


<script language="javascript">
while (1) { alert("stop that"); }
</script>
  
this isn't a problem with the javascript implementation, since an infinite loop
has it's uses, but should there be a way to break the loop from the user's end
without killing the browser?
Marking as duplicate of bug 13350. I will attach your testcase there.

*** This bug has been marked as a duplicate of 13350 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Summary: Javascript infinite loop → Javascript infinite loop
Reopening and re-duplicating, this time to bug 59314.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Sorry for all the spam.

*** This bug has been marked as a duplicate of 59314 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → DUPLICATE
Verified Duplicate. Arthur, nice catch!

Aaron: thank you for this report; you have been cc'ed on the other bug
so you can follow its progress -
Status: RESOLVED → VERIFIED
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 61098 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.