Crash in mozilla::net::nsHttpConnection::InitSSLParams

RESOLVED FIXED in Firefox 56

Status

()

Core
Networking
--
critical
RESOLVED FIXED
7 months ago
4 months ago

People

(Reporter: marcia, Assigned: dragana)

Tracking

({crash, regression})

55 Branch
mozilla56
Unspecified
Windows 10
crash, regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 disabled, firefox56 fixed)

Details

(Whiteboard: [necko-active], crash signature)

(Reporter)

Description

7 months ago
This bug was filed from the Socorro interface and is 
report bp-ed307e6d-459b-4ac5-bd7a-53e6f0170509.
=============================================================

See while looking at Nightly crash stats - crashes started using 20170508030204: http://bit.ly/2pvdVQb

Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=37a5b7f6f101df2eb292b1b6baaf1540c9920e20&tochange=1fda52a1f3b81cf1a821155998dca637bb64e3d9

Updated

7 months ago
status-firefox53: --- → affected
status-firefox54: --- → affected
(Reporter)

Comment 1

7 months ago
Hani: I don't see any crashes in the branches listed in your comment - is there a reason you are marking those branches as affected?
Flags: needinfo?(hani.yacoub)
I only see a few crashes for 55 nightly.
status-firefox53: affected → unaffected
status-firefox54: affected → unaffected

Comment 3

7 months ago
Hi Marcia, sorry for that I actually wanted to mark them as unaffected.
Flags: needinfo?(hani.yacoub)
TFO?
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1188435
Blocks: 1188435
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: nobody → honzab.moz
Whiteboard: [necko-active]
(Assignee)

Comment 5

7 months ago
i will take all of this bugs blocking 1188435.
Assignee: honzab.moz → dd.mozilla
(Reporter)

Updated

7 months ago
Flags: needinfo?(mozillamarcia.knous)
(Reporter)

Comment 6

6 months ago
TFO was turned on again in Bug 1367390, we will keep these crashes open until Dragana evaluates whether they should be closed or not.
Flags: needinfo?(mozillamarcia.knous)
(Assignee)

Comment 7

6 months ago
This crash is not present in the TFO second try, but I think this affected only one user or limited number of users. Therefore I cannot confirm that the crash is fixed, I am sure it is not fixed. There is one comment saying:
"Nightly doesn't start up anymore. Windows 10. Happened after automatic update."

All of crashes have:
pmls64.dll 	4.0.20.98 	FDD6517F76E64641AAC65AC8055732151 	OSMIMHK64.pdb
or
rlls64.dll 	4.0.20.98 	FDD6517F76E64641AAC65AC8055732151 	OSMIMHK64.pdb

We probably need to disable TFO if we detect this modules.
TFO crash, updating flags for 56.
status-firefox55: affected → disabled
status-firefox56: --- → affected
(Assignee)

Updated

4 months ago
Status: REOPENED → RESOLVED
Last Resolved: 7 months ago4 months ago
Resolution: --- → FIXED
status-firefox56: affected → fixed
Target Milestone: --- → mozilla56
status-firefox-esr52: --- → unaffected
You need to log in before you can comment on or make changes to this bug.