Crash in W8_mark_pixelshape

RESOLVED FIXED in Firefox 55

Status

()

--
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: marcia, Assigned: jfkthame)

Tracking

({crash, regression, reproducible})

55 Branch
mozilla55
Unspecified
Mac OS X
crash, regression, reproducible
Points:
---

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 fixed)

Details

(crash signature)

Attachments

(1 attachment)

This bug was filed from the Socorro interface and is 
report bp-22d135ca-fa12-4a14-abcd-95c150170508.
=============================================================

Seen while looking at Mac specific crash stats - small volume crash that started using 20170501030204: http://bit.ly/2qZabYr

In the app notes of one report there is this error:

NSInvalidArgumentException: *** -[__NSPlaceholderDictionary initWithObjects:forKeys:count:]: attempt to insert nil object from objects[30]
Obj-C Exception data:
NSInvalidArgumentException: *** -[__NSPlaceholderDictionary initWithObjects:forKeys:count:]: attempt to insert nil object from objects[30]

possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2fe636103d7167f3a5d57f61bd19fddcc878ca3c&tochange=076a7a66096f9e8d102548397254be32eb26bc3d

Was able to reproduce by following the lead of one comment:

1. Visit https://devhub.io/repos/metasoarous-datsync
2. File | Print | Save as PDF
3. Crash - easily reproducible.

Should this be moved to Printing. ni on markus to help put it in the right bucket since it is a reproducible issue.
Flags: needinfo?(mstange)
Flags: needinfo?(mstange) → needinfo?(jwatt)
Graphics seems like the right component because it looks like it's Moz2D that's crashing during the printing replay.
Maybe related to bug 1355931?
Flags: needinfo?(jwatt) → needinfo?(lsalzman)
(Assignee)

Comment 3

2 years ago
Created attachment 8866492 [details] [diff] [review]
Ensure ScaledFontMac constructor always initializes the mFont field properly
Attachment #8866492 - Flags: review?(lsalzman)
(Assignee)

Updated

2 years ago
Assignee: nobody → jfkthame
Status: NEW → ASSIGNED
Flags: needinfo?(lsalzman)
Attachment #8866492 - Flags: review?(lsalzman) → review+
Blocks: 1355931
Has Regression Range: --- → yes
Has STR: --- → yes
status-firefox53: --- → unaffected
status-firefox54: --- → unaffected
status-firefox-esr45: --- → unaffected
status-firefox-esr52: --- → unaffected
(Assignee)

Comment 4

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/6bd4f71f04bc6f13d61fd26717a8dc41062ddabb
Bug 1363492 - Ensure ScaledFontMac constructor always initializes the mFont field properly. r=lsalzman
https://hg.mozilla.org/mozilla-central/rev/6bd4f71f04bc
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox55: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.