Closed Bug 1363570 Opened 4 years ago Closed 2 years ago

One-off search buttons: Alt-Up/Down isn't working on Linux

Categories

(Firefox :: Address Bar, defect, P2)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: adw, Unassigned)

References

Details

(Whiteboard: [fxsearch])

Alt-Up/Down should cycle through the one-off buttons.  For some reason on Linux, you have to press Shift-Alt-Up/Down.  I don't know whether that's always been the case or whether we (I) broke it recently.

Simona, do you think you could get a regression range?  If it is a regression, it's probably due to bug 1180944 or bug 1295458.  Since I'm not sure yet, I won't mark this blocking a particular bug yet.
Flags: needinfo?(simona.marcu)
(In reply to Drew Willcoxon :adw from comment #0)
> For some reason on Linux, you have to press Shift-Alt-Up/Down.

I can't see why that should be the case, looking at the code, by the way.
On Firefox 51 (Build ID: 20170116133120), I see the same behavior as on the latest Nightly 55.0a1 (Build ID: 20170509100208) - navigation in the one-offs bar can't be made using just Alt+Up/Down (works with Shift+Alt+Up/Down). 

I went back to Firefox 49.0.2 and Firefox 34 and the navigation in the search one-offs bar (in the search bar) is made also using Shift+Alt+Up/Down. This leads me to believe that the keyboard navigation in the one-offs bar was designed this way. Drew, what is your opinion on this?
Flags: needinfo?(simona.marcu)
Thanks!  It's good to know it's not a recent regression.  I haven't poked around on Linux with this specifically, but just being familiar with the code, I don't see exactly why Linux should behave differently.  It's worth investigating and fixing probably, but since it's not a recent regression, probably not a high priority.  ... although if it's always worked this way on Linux, maybe we shouldn't "fix" it!

This works for me in the quantum bar

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.