Closed Bug 1363756 Opened 3 years ago Closed 2 years ago

Remove work-around for delayed, 'jumping' panel resizing issue

Categories

(Firefox :: Toolbars and Customization, enhancement, P4)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1428839

People

(Reporter: mikedeboer, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [reserve-photon-structure])

In bug 1354141, we saw that the panel height is not adjusted quickly enough when the panel contents changes. Therefore we added a work-around that sets the height we expect it to have and remove these static properties 500ms later.
Practice showed that relying on 'MozAfterPaint' for this was not reliable enough to get rid of the jank.
Flags: qe-verify-
This will be fixed by bug 1009116.
Depends on: 1009116
Whiteboard: [photon-structure] → [reserve-photon-structure]
Blocks: 1364672
(In reply to :Paolo Amadini from comment #1)
> This will be fixed by bug 1009116.

This bug was actually unrelated, but finding out what happens here might help in removing the second synchronous layout in the non-Photon code path from bug 1363756.
...from bug 1009116.
Blocks: 1359894
Priority: P3 → P4
bug 1428839 is removing this code.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1428839
You need to log in before you can comment on or make changes to this bug.