Search in new tab only if current tab is not new tab page

RESOLVED DUPLICATE of bug 1455326

Status

()

defect
RESOLVED DUPLICATE of bug 1455326
2 years ago
2 months ago

People

(Reporter: mario66, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170504112025

Steps to reproduce:

Use case 1:
1. Open a new empty tab
2. Type text in search bar
3. Hit enter (i.e. perform search)

Use case 2:
1. Navigate to a website
2. Type text in search bar
3. Hit enter (i.e. perform search)


Actual results:

Firefox opens a new tab in case 1 and case 2 if the pref "browser.search.openintab" is true.

Firefox does not open a new tab in case 1 and case 2 if the pref "browser.search.openintab" is false.


Expected results:

Add an option such that Firefox opens a new tab in case 1, but *not* in case 2.

Basically, mirror the behavior of the following addon: https://addons.mozilla.org/de/firefox/addon/search-in-new-tab/

The reason why I report this even though there is an addon for this is that your management has decided to set everything on fire and exterminate all user interface related addons soon. Hence, I though you may be interested in providing such a feature out-of-the-box. I think this a very useful feature!
Component: Untriaged → Search
Reporter

Updated

2 years ago
Severity: normal → enhancement

From the summary, I think the expected results should be that Firefox opens a new tab in case 2 butnot in case 1.

This was fixed in bug 1455326, hence duping to that bug.

Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1455326
You need to log in before you can comment on or make changes to this bug.