If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

transitions involving transformations inside of a masked region cause graphic glitches

RESOLVED DUPLICATE of bug 1362000

Status

()

Core
Layout: Web Painting
RESOLVED DUPLICATE of bug 1362000
5 months ago
5 months ago

People

(Reporter: Iiro, Assigned: cjku)

Tracking

({regression})

53 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox53- wontfix, firefox54+ fixed, firefox55+ fixed)

Details

(Reporter)

Description

5 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170413192749

Steps to reproduce:

Create an svg element (rectangle) and make it translate via transition on hover event. Put the rectangle inside of a masked region: <g mask="...><rect...></g> Hover the mouse around...

I put the basic example here: http://codepen.io/iiroullin/pen/oWEOOM


Actual results:

When the mouse is moved in and out of zone triggering the transition, the rectangle occasionally erratically hops penetrating outside of the masked region



Expected results:

1) The rectangle shouldn't hop
2) The rectangle shouldn't penetrate outside of the masked region

Updated

5 months ago
Component: Untriaged → Layout: Web Painting
Product: Firefox → Core
(Reporter)

Comment 1

5 months ago
It seems that this bug is new to Firefox 53.0: I had an older version (52...) on my laptop and it did not have this bug. As soon as it updated, the bug appeared!

Comment 2

5 months ago
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=0005d0bfadf72746ce36f4e8d09d9504b814557e&tochange=ba20391edbec448b56725ef01158176614706b4f

Looks like the following bug has the  changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1313898

cku, could you check this regression from your bugfix, please.
Blocks: 1313898
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
status-firefox53: --- → affected
status-firefox54: --- → affected
status-firefox55: --- → affected
tracking-firefox53: --- → ?
tracking-firefox54: --- → ?
tracking-firefox55: --- → ?
Ever confirmed: true
Flags: needinfo?(cku)
Keywords: regression
(Assignee)

Updated

5 months ago
Assignee: nobody → cku
Flags: needinfo?(cku)
(Assignee)

Updated

5 months ago
See Also: → bug 1362000
(Assignee)

Updated

5 months ago
See Also: → bug 1350663
(Assignee)

Comment 3

5 months ago
Yes, I am currently look into this problem. The position of a mask layer is not updated correctly.
Tracking for 54/55.
status-firefox53: affected → wontfix
tracking-firefox53: ? → -
tracking-firefox54: ? → +
tracking-firefox55: ? → +
(Assignee)

Updated

5 months ago
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1362000

Comment 6

5 months ago
fixed&uplifted in the dupe
status-firefox54: affected → fixed
status-firefox55: affected → fixed
You need to log in before you can comment on or make changes to this bug.