Closed Bug 1363940 Opened 2 years ago Closed 2 years ago

Intermittent text/wordwrap-02.html == text/wordwrap-02-ref.html | image comparison, max difference: 1, number of differing pixels: 1

Categories

(Core :: Layout: Text and Fonts, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox57 --- fixed
firefox58 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jfkthame)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed:other])

Attachments

(1 file)

Priority: -- → P3
this started on oct 2nd as a high frequency failure, I have just kicked off some retriggers to maybe identify the root cause:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-searchStr=reftest-44&tochange=b00cd35474a0ffa96b76ed255eb35a3763b51be2&fromchange=f1251736514da97cf8065f631f0c93ce5c8695c7&selectedJob=134302667

:jfkthame, this has started (perma?) failing on android in the last 2 days, is this something you can take a look at or recommend disabling?
Flags: needinfo?(jfkthame)
Whiteboard: [stockwell needswork]
I have no idea why this has suddenly become more frequent, but AFAICS (at least in the cases I've looked at) the discrepancy is just a single corner pixel of the textarea's frame; it's nothing to do with the content actually being tested. As such, I would vote for just annotating it as fuzzy and moving on.
Flags: needinfo?(jfkthame)
If you can pinpoint a recent regression (IMO this looks more like a graphics than layout issue, actually), maybe we can do something, but otherwise this is what I'd suggest.
the retriggers didn't show any patterns/root causes, I would recommend r? for the fuzzy patch.
Attachment #8915120 - Flags: review?(dholbert)
Bug 1363945 is just the same: upper right pixel, failing frequently on Android beginning around when the changes for bug 
1381434 landed. I've ni'd schien in bug 1363945. (But this was a pre-existing problem...fuzzy-if might be the best way forward.)
Blocks: 1381434
See Also: → 1363945
(In reply to Geoff Brown [:gbrown] from comment #25)
> upper right pixel

Sorry -- upper left pixel.
I guess bug 1381434 is likely to have affected timing of the webfont load used in these tests, and in turn that probably affects (re)painting behavior, e.g. depending whether or not the completion of the font load triggers an additional reflow/paint cycle after the initial page load has happened.
Comment on attachment 8915120 [details] [diff] [review]
Mark testcase as fuzzy on Android due to unreliable corner pixel of the frame

Review of attachment 8915120 [details] [diff] [review]:
-----------------------------------------------------------------

r=me
Attachment #8915120 - Flags: review?(dholbert) → review+
Pushed by jkew@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/10ca1d0023d7
Mark testcase as fuzzy on Android due to unreliable corner pixel of the frame. r=dholbert
I assume this is fixed, we haven't merged in a while.
Whiteboard: [stockwell disable-recommended] → [stockwell needswork]
https://hg.mozilla.org/mozilla-central/rev/10ca1d0023d7
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Assignee: nobody → jfkthame
Whiteboard: [stockwell disable-recommended] → [stockwell fixed:other]
You need to log in before you can comment on or make changes to this bug.