Firefox fails to load additional pages after a while

RESOLVED DUPLICATE of bug 1360574

Status

()

RESOLVED DUPLICATE of bug 1360574
a year ago
a year ago

People

(Reporter: benjamin.thery, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8866741 [details]
about_networking_http_connections.csv

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170504112025

Steps to reproduce:

After I start Firefox it works fine for a while. It can display all pages without problem.

But, after a while it suddenly fails to load any page (even reload the ones that were loaded previously). It is spinning infinitely. No error are displayed in the browser.

(a while == could be minutes or hours depending one the number of pages loaded before it fails)

Other browsers have no issue, so this is not a network connectivity issue.

Quitting and restarting Firefox solve the issue.



Actual results:

Firefox is unable to load any additional page after a while.
It is reproducible with every Firefox sessions I start on this system.

Did some investigations.
Once it happens, about:networking, HTTP tab, shows that there are exactly 900 active connections. Which matches the configuration option network.http.max-connections

It looks like a resource leak. Connections should probably not stay active once the pages are loaded. For some reason some (most?) connections are never closed on my system.
(attached to this bug report is a csv file of the data displayed in about:networking once the issue occurs)

I tested another system with Firefox, and the issue is not present. about:networking shows most HTTP connections are not active after browsing.

On the faulty system I changed the value of  network.http.max-connections to 256, and as expected Firefox stopped loading additional pages once I see 256 active connections in about:networking.

This confirms there is a link between the issue the this max connection counter.

I did a "refresh" to reset all firefox settings. Issue is still there.
I desinstalled and resinstalled the same version of Firefox on the system. Issue is still there.

Exact Firefox version is ESR 52.1.1 (Windows / 32-bit)





Expected results:

Firefox should be able to load additional pages. 
Most HTTP connections should not be considered as active after the page are loaded.
Component: Untriaged → Networking: HTTP
Product: Firefox → Core

Comment 1

a year ago
Do you use a proxy?

Comment 2

a year ago
Could be a duplicate of bug 1360574
Sounds like that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1360574
(Reporter)

Comment 4

a year ago
Correct, I'm behind a HTPP proxy that uses NTLMv2 authentication.
You need to log in before you can comment on or make changes to this bug.