All users were logged out of Bugzilla on October 13th, 2018

An HTML HR is not constrained to its containing DIV

RESOLVED DUPLICATE of bug 84887

Status

()

P2
normal
RESOLVED DUPLICATE of bug 84887
17 years ago
5 years ago

People

(Reporter: stephen.moehle, Assigned: attinasi)

Tracking

({testcase})

Trunk
Future
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
On a page with two side-by-side DIVs and one of the DIVs has an HR element, the
HR will extend across the entire page rather than being constrained to the
containing DIV.  I think this is wrong.  So evidently does the person who wrote
the Blogging software used by EFF.

I will attach a simplified testcase which looks fine in IE6 and NN4 but not in
Mozilla.

Tested with Mozillla trunk 2002-04-09-03 on Win2000.
(Reporter)

Comment 1

17 years ago
Created attachment 78378 [details]
Simplified testcase

Comment 2

17 years ago
Changing QA contact
QA Contact: petersen → moied

Comment 3

17 years ago
Confirmed with build 20020416 on winXp
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Updated

17 years ago
Priority: -- → P2

Updated

17 years ago
Target Milestone: --- → Future

Updated

17 years ago
Keywords: testcase
Created attachment 111107 [details]
Test above with colours

Adding colours to the previous test file shows the HR is correctly the width of
it's parent DIV, but that the DIVs are not side by side.
So the DIVs are not side by side as blue is a float and does not affect the box
of red ... so should the HR count as a line box (and act as the text does and
flow around the float) or a block box as it seems to now?
Created attachment 111165 [details]
Same test case with no DOCTYPE.
HR is a block level element according to my HTML 4.01 sidebar so the testcase
give which has strict DOCTYPE seems to be correct behaviour.  Taking out the
doctype gives the behaviour that the reporter expects.  So I think this bug
should be closed INVALID.

*** This bug has been marked as a duplicate of 84887 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.