WebExtensions and near future killing of statusbar/addonbar (?)

RESOLVED DUPLICATE of bug 1215064

Status

()

Toolkit
WebExtensions: General
RESOLVED DUPLICATE of bug 1215064
a year ago
11 months ago

People

(Reporter: Andrei Boros, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
This is a complex, delicate matter and mostly indirect. 
But I feel I should voice it. 

I've been using ForecastFox extentions for a long time.
After the original extension was abandoned, and this one took it's place http://www.s3blog.org/forecastfox.html , myself and many users were very happy with it. 

Recently however this extension was rewritten, partly to adapt Forecastfox under the new Mozilla requirements, related to WebExtensions and changes scheduled to take place by november 2017. 

The new version of the ForecastFox extension is lacking essential functionality, like the display of several days worth of forecast with additional details.
According to the author of this extension, the reason is the following: 
- he removed the status bar / addon bar parts of the functionality of his extension in order to comply with new Mozilla requirements.

The author of this extension is under considerable user pressure because of lost functionality. However, he describes that those losses are not because of his intention, but because of constraints put forth by Mozilla.
See the full post here: http://forums.mozillazine.org/viewtopic.php?p=14747274#p14747274

I must admit I knew nothing about this until now. 

But I cannot remain silent, even if others did, and voice a request for statusbar in WebExtensions.

I don't argue against WebExtensions. I sincerely hope they bring better user experience and more functional and performance value to the users. 
However, such loss of functionality isn't value added for the users.
Component: Untriaged → WebExtensions: General
Product: Firefox → Toolkit

Updated

11 months ago
Flags: needinfo?(amckay)

Updated

11 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Flags: needinfo?(amckay)
Resolution: --- → DUPLICATE
Duplicate of bug: 1215064
You need to log in before you can comment on or make changes to this bug.