stylo: need support for CSS_PSEUDO_CLASS_ENABLED_IN_UA_SHEETS_AND_CHROME on pseudo-classes

RESOLVED DUPLICATE of bug 1381851

Status

()

Core
CSS Parsing and Computation
P2
normal
RESOLVED DUPLICATE of bug 1381851
10 months ago
7 months ago

People

(Reporter: bz, Unassigned)

Tracking

(Blocks: 1 bug)

53 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Gecko pseudo-classes can be enabled in one of three places:

1)  Everywhere (no flags)
2)  In UA sheets only (CSS_PSEUDO_CLASS_ENABLED_IN_UA_SHEETS)
3)  In UA sheets and chrome sheets (CSS_PSEUDO_CLASS_ENABLED_IN_UA_SHEETS_AND_CHROME)

What stylo seems to have, in non_ts_pseudo_class_list is a single flag (PSEUDO_CLASS_INTERNAL) whose behavior, I think, corresponds to CSS_PSEUDO_CLASS_ENABLED_IN_UA_SHEETS.  There seems to be no equivalent of CSS_PSEUDO_CLASS_ENABLED_IN_UA_SHEETS_AND_CHROME.
Are we going to support chrome document in Stylo's MVP? If not, I guess this isn't a high priority thing.
> Are we going to support chrome document in Stylo's MVP?

The question isn't whether we support chrome _document's_ but whether we support chrome _stylesheets_.

We're certainly going to support some of those (e.g. chrome://global/skin/resizer.css better be supported).  The question is whether any of them use the relevant pseudo-classes.

Just did some spot-checking, and looks to me like :-moz-handler-crashed is used in the pluginproblem bits, and those sheets are pulled into random content documents as needed.

Updated

9 months ago
Priority: -- → P3

Updated

7 months ago
Priority: P3 → --
Priority: -- → P2
TY's doing this as part of bug 1381851.
Depends on: 1381851
The patches in bug 1381851 has implemented PSEUDO_CLASS_ENABLED_IN_UA_SHEETS_AND_CHROME, so mark this bug as a dup.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1381851
You need to log in before you can comment on or make changes to this bug.