If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

need to add publish error strings

VERIFIED DUPLICATE of bug 148425

Status

SeaMonkey
Composer
VERIFIED DUPLICATE of bug 148425
16 years ago
13 years ago

People

(Reporter: sujay, Assigned: Charles Manske)

Tracking

Trunk
mozilla1.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: publish)

(Reporter)

Description

16 years ago
this is from bug 134182

Kathy mentioned this issue in that bug.
(Assignee)

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 126258 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
reopen bug; I don't think this is a duplicate bug
if we need to add more strings to give users better feedback, we'll probably
need special localization approval so a specific bug with strings should be better.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 3

16 years ago
Adding Robin to cc.
FYI: These are strings we use now:
PublishFailed=Publishing failed!
PublishNoAccess=No access to    // Not used currently
PublishDirFailed=The subdirectory %dir% doesn't exist at this site
PublishCompleted=Publishing completed
PublishSomeFileFailed=Some files failed to publish

* Used in Publish dialog:
MissingSiteNameError=Please enter a name for this publishing site.
MissingPublishUrlError=Please enter a location for publishing this page.
MissingPublishFilename=Please enter a filename for the current page.
MissingPublishSiteError=No publishing site information given. Switching to
Settings panel so you can supply publishing information.
DuplicateSiteNameError="%name%" already exists. Please enter a different site name.
Status: REOPENED → ASSIGNED

Comment 4

16 years ago
PublishFailed=Publishing failed!
PublishSomeFileFailed=Some files failed to publish

For these two error messages, I'd like to tell the user how they can remedy the
error. If you can tell me what causes these errors to appear, then I'll suggest
some wording to add to these error messages that may allow the user to prevent
the error from occurring.

PublishDirFailed=The subdirectory %dir% doesn't exist at this site

Suggested wording: "The subdirectory %dir% doesn't exist at this site. Try
creating this subdirectory (using an FTP program) or else choose a different
subdirectory, and try again."


MissingPublishSiteError=No publishing site information given. Switching to
Settings panel so you can supply publishing information.

Suggested wording: "No publishing settings exist for this document. The Settings
panel wil be displayed so you can enter the publishing settings."
(Assignee)

Comment 5

16 years ago
Robin: Good suggestions.
Adding keywords so we are sure to address these for rtm.
Keywords: nsbeta1
Whiteboard: publish[RTM][adt3]
Target Milestone: --- → mozilla1.0

Comment 6

16 years ago
PublishFailed=Publishing failed!
PublishSomeFileFailed=Some files failed to publish

For these two error messages, I'd like to tell the user how they can remedy the
error or prevent the error from occurring. I realize that we may not be able to
identify all the scenarios that might cause these errors. 

What are some of the most common reasons why these errors occur? What are the
suggested remedies for these common scenarios?
(Assignee)

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1+
Whiteboard: publish[RTM][adt3] → publish[RTM]

Updated

16 years ago
Whiteboard: publish[RTM] → publish[adt 2 rtm]

Updated

16 years ago
Whiteboard: publish[adt 2 rtm] → publish[adt2 rtm]

Comment 7

16 years ago
Adding custrtm-; no impact on customization.

Updated

16 years ago
Whiteboard: publish[adt2 rtm] → publish[adt2 rtm],custrtm-
(Assignee)

Comment 8

16 years ago
We need to supply better error messages for publishing as well as a way to help
user fix problems. Bug 148425 covers the all the related issues.

*** This bug has been marked as a duplicate of 148425 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

16 years ago
Whiteboard: publish[adt2 rtm],custrtm- → publish
(Reporter)

Comment 9

16 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.