Closed Bug 1364662 Opened 3 years ago Closed 8 hours ago

Crash in mozilla::MozPromise<T>::MozPromise<T>

Categories

(Core :: XPCOM, defect, P3)

55 Branch
Unspecified
Windows 7
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr60 --- affected
firefox55 --- wontfix

People

(Reporter: calixte, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression, Whiteboard: [clouseau])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-9a7061d9-f8a1-4bfc-9108-c5fe30170513.
=============================================================

There is 1 crash in nightly 55 with buildid 20170512030203. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1362912.

[1] https://hg.mozilla.org/mozilla-central/rev?node=f3590d95b1a6716f342cc778d3f1c6a8b18c3ce0
Flags: needinfo?(jwwang)
I don't think this is a regression from bug 1362912 or bug 1362910.

We have bp-67b0a71d-ad1f-4dfb-87ca-6eb1b0170423 which also crashed in mozilla::MozPromise<T>::CreateAndResolve<T>. In fact, we have several MozPromise crashes which look like memory corruption.
Flags: needinfo?(jwwang)
Severity: critical → normal
Priority: -- → P3
Closing because no crashes reported for 12 weeks.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
There are still some crashes so reopen it.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Closing because no crashes reported for 12 weeks.

Status: REOPENED → RESOLVED
Closed: Last year8 hours ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.