2.68ms uninterruptible reflow at updateLWTStyling@resource://app/modules/CustomizeMode.jsm:669:23

RESOLVED DUPLICATE of bug 1358722

Status

()

defect
RESOLVED DUPLICATE of bug 1358722
2 years ago
2 years ago

People

(Reporter: rjward0, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ohnoreflow][qf:p3])

Reporter

Description

2 years ago
Here's the stack:

updateLWTStyling@resource://app/modules/CustomizeMode.jsm:669:23
observe@resource://app/modules/CustomizeMode.jsm:1537:11
_update@resource://gre/modules/LightweightThemeConsumer.jsm:167:5
observe@resource://gre/modules/LightweightThemeConsumer.jsm:63:5
_notifyWindows@resource://gre/modules/LightweightThemeManager.jsm:794:3
resetPreview@resource://gre/modules/LightweightThemeManager.jsm:242:7
resetPreview@resource://app/modules/CustomizeMode.jsm:1348:7
EventListener.handleEvent*buildToolbarButton@resource://app/modules/CustomizeMode.jsm:1384:9
onLWThemesMenuShowing/<@resource://app/modules/CustomizeMode.jsm:1410:22
safeCall@resource://gre/modules/AddonManager.jsm:190:5
makeSafe/<@resource://gre/modules/AddonManager.jsm:205:25
process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:922:23
walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:806:7
Promise*scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:739:11
schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:770:7
Promise.prototype.then@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:455:5
getAddon@resource://gre/modules/addons/XPIProvider.jsm -> resource://gre/modules/addons/XPIProviderUtils.js:1073:12
getVisibleAddonForID@resource://gre/modules/addons/XPIProvider.jsm -> resource://gre/modules/addons/XPIProviderUtils.js:1122:5
getAddonByID@resource://gre/modules/addons/XPIProvider.jsm:4270:5
callProviderAsync@resource://gre/modules/AddonManager.jsm:292:12
promiseCallProvider/<@resource://gre/modules/AddonManager.jsm:316:53
Promise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:390:5
promiseCallProvider@resource://gre/modules/AddonManager.jsm:315:10
getAddonByID/promises<@resource://gre/modules/AddonManager.jsm:2413:12
getAddonByID@resource://gre/modules/AddonManager.jsm:2412:20
getAddonByID@resource://gre/modules/AddonManager.jsm:3550:7
onLWThemesMenuShowing@resource://app/modules/CustomizeMode.jsm:1357:5
onpopupshowing@chrome://browser/content/browser.xul:1:1
Component: Untriaged → Toolbars and Customization
Flags: qe-verify?
Priority: -- → P2
Priority: P2 → P3
Whiteboard: [ohnoreflow][qf][photon-performance] → [ohnoreflow][qf][reserve-photon-performance]
Flags: qe-verify? → qe-verify-
Whiteboard: [ohnoreflow][qf][reserve-photon-performance] → [ohnoreflow][qf:p3][reserve-photon-performance]

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1358722
Flags: qe-verify-
Priority: P3 → --
Whiteboard: [ohnoreflow][qf:p3][reserve-photon-performance] → [ohnoreflow][qf:p3]
You need to log in before you can comment on or make changes to this bug.