Closed Bug 1364732 Opened 3 years ago Closed 3 years ago

KATAKANA MIDDLE DOT (U+30FB) in ruby is too large on OSX

Categories

(Core :: Layout, defect, minor)

x86_64
macOS
defect
Not set
minor

Tracking

()

RESOLVED INVALID

People

(Reporter: arai, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Steps to reproduce:
  1. open Firefox Nightly with clean profile on OSX (Japanese environment)
  2. open https://ja.wikipedia.org/wiki/Load-Link/Store-Conditional
  3. look at the 1st line of the 1st paragraph

Actual result:
  KATAKANA MIDDLE DOT (U+30FB) in "ロード・アンド・リザーヴ" over "load and reserve" is too large, compared to other KATAKANA characters in ruby text (see attached screenshot)

Expected result:
  all ruby texts are scaled samely or similarly
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
Severity: normal → minor
I suspect this is because of using "ruby" font feature again...

ni? myself for investigation anyway...
Flags: needinfo?(xidorn+moz)
So my guess is correct, this is because of the ruby font feature. If you use the following code:
> <p style="font-variant-east-asian: ruby">ロード・アンド・リザーヴ</p>
you can see the same effect without ruby.

Since other browsers don't support font-variant-east-asian property yet, you have to use this code:
> <p style="font-feature-settings: 'ruby'">ロード・アンド・リザーヴ</p>
to show that in other browsers.

That says, a properly designed font usually use heavier glyph for ruby text, so it is somehow by design of the font.

Given this, I'd say this bug is INVALID.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(xidorn+moz)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.