Closed Bug 1365173 Opened 3 years ago Closed 3 years ago

[compact themes] back button UI glitch during startup

Categories

(Firefox :: Theme, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: dietrich, Unassigned)

References

(Blocks 1 open bug)

Details

My session still takes around 30s to start up, so these types of visual glitches are really glaring.

I'm pretty sure this began after all the lazy tab fixes.

Screenshot: https://i.imgur.com/CTtTCQJ.png

I've 389 tabs (according to gBrowser.tabs.length), so you'll need a decently sized session to reproduce. I haven't tried to find out what the minimum number of tabs required to see this is, but that's probably worth doing.

Maybe not worth fixing given the atypical session size, but thought I'd report anyway.
Hmm, this might also be not related to sessionstore at all, but with all the recent patches landing related to SVG icons and other toolbar updates.
N-i'ing Dão to be sure.
Flags: needinfo?(dao+bmo)
Does this happen without the compact theme?
Flags: needinfo?(dao+bmo) → needinfo?(dietrich)
Only compact theme.
Flags: needinfo?(dietrich)
Component: Session Restore → Theme
Whiteboard: [photon-visual][p3]
Summary: back button UI glitch during startup while session is restoring → back button UI glitch during startup
Flags: qe-verify?
Priority: -- → P2
Flags: qe-verify? → qe-verify+
QA Contact: brindusa.tot
Summary: back button UI glitch during startup → [compact themes] back button UI glitch during startup
Same/similar glitch on dark compact theme from latest nightly: https://i.imgur.com/9BeRk3U.png
Flags: qe-verify+
Priority: P2 → --
QA Contact: brindusa.tot
Whiteboard: [photon-visual][p3]
I don't think this is an issue anymore in Nightly.

55 or 56 might still be affected, not sure; doesn't seem worth to spend time on this.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.