Allow override of ContextMenus/ACTION_MENU_TOP_LEVEL_LIMIT

RESOLVED DUPLICATE of bug 1294429

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1294429
3 months ago
3 months ago

People

(Reporter: Geoffrey De Belie (Smile4ever), Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170514030207

Steps to reproduce:

Currently you can only have one top-level contextmenu item when using the WebExtensions contextmenus API. This is because ContextMenus/ACTION_MENU_TOP_LEVEL_LIMIT is set to 1.

I would like to make three proposals:
1. Allow WebExtensions to provide an override for ContextMenus/ACTION_MENU_TOP_LEVEL_LIMIT in their manifest
2. Increase ContextMenus/ACTION_MENU_TOP_LEVEL_LIMIT to 3 (instead of one)
3. Add an API to set the ContextMenus/ACTION_MENU_TOP_LEVEL_LIMIT from code

Any of these is better than none at all.

Updated

3 months ago
See Also: → bug 1294429
ACTION_MENU_TOP_LEVEL_LIMIT has nothing to do with this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1294429
You need to log in before you can comment on or make changes to this bug.