Webextensions manifest field for hiding Mozilla Extensions from the add-on listing

VERIFIED FIXED in Firefox 63

Status

()

P1
normal
VERIFIED FIXED
2 years ago
3 months ago

People

(Reporter: aswan, Assigned: aswan)

Tracking

unspecified
mozilla63
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox63 verified, firefox64 verified)

Details

(Whiteboard: triaged)

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
The original bug will just handle bootstrapped addons with the flag in install.rdf.  This bug is to eventually do the same for webextensions

+++ This bug was initially created as a clone of Bug #1363624 +++

SHIELD studies are managed by the SHIELD system add-on instead of the add-on manager, and should not appear in the about:addons listing (SHIELD will have it's own listing for studies). After discussing it via IRC, aswan suggested we add a field to the install manifest for bootstrapped Mozilla Extensions that lets them mark themselves as hidden from the about:addons extension listing.

Updated

2 years ago
Assignee: nobody → aswan
Priority: -- → P1
Whiteboard: triaged
(Assignee)

Comment 1

2 years ago
Whoops, I confused this with bug 1363624 during triage.  Adjusting the priority and un-assigning myself.
Assignee: aswan → nobody
Priority: P1 → P5
Priority: P5 → P1
(Assignee)

Updated

5 months ago
Assignee: nobody → aswan
Assignee: aswan → nobody
(Assignee)

Updated

5 months ago
Assignee: nobody → aswan
(Assignee)

Comment 2

4 months ago
Created attachment 8998093 [details]
Bug 1365349 Allow shield studies to not appear in about:addons

MozReview-Commit-ID: 114dbRtFIjP
Part of:  https://github.com/mozilla/shield-studies-addon-utils/issues/246  The "Better Study Endings" Engineering plan.  

Define:

* "study addon", a 'signed' webExtension designed as a data gathering mechanism, as part of the Shield and Pioneer programs.

(For reference)

Solves:  

- hide 'shield study' and some other addons from `about:addons`.
- so that users do not panic when they install
- so that ending the study doesn't leave an 'undo' state.


Mechanism:
- adds new (optional) key "hidden" to Manifest.json
- reuse the existing `hidden()` function, currently used by System Addons
- in `manifest.json`, add key `"hidden": true`.
- in XPIDatabase.jsm (called by `about:addons`)
- if `hidden: true` AND the addon has "Privileged Signature", hide the addon.


No change:
- Studies appear in `about:support`, `about:studies` (tracked by Normandy)
- Studies appear in Telemetry (filted by ID at analysis time)
- addons should still appear in `about:debugging`, be loadable by web-ext, etc.


Study build note:  to Enable for an Addon:

- in `manifest.json`, add key `"hidden": true`.  While 'unsigned', the addon will still appear.
Comment on attachment 8998093 [details]
Bug 1365349 Allow shield studies to not appear in about:addons

Kris Maglione [:kmag] has approved the revision.
Attachment #8998093 - Flags: review+

Comment 6

4 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/bf4d25714742
Status: NEW → RESOLVED
Last Resolved: 4 months ago
status-firefox63: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Can we please get STR for QA, or qe-verify- if already covered?
Flags: needinfo?(aswan)
(Assignee)

Comment 8

3 months ago
Covered by automated tests.
Manual testing would require signing an extension with a privileged signature, probably easier to just wait until Shield starts using this and then make it part of the QA process for individual studies.
Flags: needinfo?(aswan) → qe-verify-
See Also: → bug 1491074
I have verified that the issue is no longer reproducible on the latest Beta 63.0b10 (Build ID 20180927143327) and the latest Nightly 64.0a1 (Build ID 20181001220118) on Windows 10 x64, Mac 10.13, and Ubuntu 18.04 x64. Add-ons with the `"hidden": true` property are no longer displayed in the about:addons page.

I have used a signed version of the Block Autoplay Shield Study addon and have verified that the addon appears to be enabled in the "about:support" page.
Status: RESOLVED → VERIFIED
status-firefox63: fixed → verified
status-firefox64: --- → verified
You need to log in before you can comment on or make changes to this bug.