Status

()

Core
Layout
P4
normal
RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: Jeremy Sanders, Assigned: Marc Attinasi)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020409
BuildID:    2002040908

The javascript pop-up menus in this page are broken (try moving the mouse over
the links in the dark green band across the top of the page). The text doesn't
show up. The triangular pop-up thinks on the "agent site" and "consumer site"
links also overlap with the bar which they don't do on other browsers. They work
in NS4, Opera and Konq. I'm not sure whether it is the web page or the browser
which is the problem (I don't do javascript!).


Reproducible: Always
Steps to Reproduce:
1. Go to http://www.landg.com/
2. Move mouse over links "about us", "media centre..."
3.

Actual Results:  Menus show up with the text not visible.


Expected Results:  Mozilla should render the menus properly.

Comment 1

16 years ago
it isn't quite broken - the text is there, but i have to select it to see it
since the text shade of blue is barely different from the blue background.

MSIE6 shows white text on green background (and yellow on hover).
Mozilla shows blue text on blue background - no hover effect.

Seems all the intended font formatting is lost in Mozilla, along with
background/clor of top tabs middle field

Comment 2

16 years ago
This seems to be the problem:
<script language="Javascript" type="text/javascript">
	document.write(getStylesheet());
</script>

getStylesheet() will return the location of the stylesheet (the page uses
another stylesheet for ie than netscape (opera...)

The links in the menu just got the default color (blue) ..
summary: mozilla doesn't get the stylesheed 'masternn.css'

i'll look deeper inside this later :) .. now i've got to go eating :)
(Reporter)

Comment 3

16 years ago
Interestingly, it does work with NS 6.2.1, so either this is a regression or the
browser detection in this page is broken...

Comment 4

16 years ago
This is strange:

http://www.blinkenlights.ch/bugzilla/case.html

that works (and thats the method like the page is loading the browserspecific CSS)

so the browser identification can't be broken..
- Mozilla is 'detectet' as Opera and got the IE Stylesheed (Netscape 6.2 would
get the NS stylesheet..)
ok.. but Mozilla handles the IE stylesheet fine.. hmm.. (the tespage uses the ie
stylesheet)

hmmmmmm...

Comment 5

16 years ago
Ok, now something very weired:

1) Mirror the page with wger -r or something like this (note: wget won't get
some CSS (masterie.css for example.. you'll have to download them by hand..)
2) Now setup a webserver and place the page into the html root

-> The page works fine (see http://www.blinkenlights.ch/bugzilla/langdlocal.jpg)

So it can't be a CSS or JavaScript problem (i tested it with mini_httpd)

Has mozilla a problem with the webserver?

Netcraft:
The site www.landg.com is running Netscape-Enterprise/4.1 on NT4/Windows 98.

hmm.. networking problem of mozilla or broken webserver?

Comment 6

16 years ago
Changing QA contact
QA Contact: petersen → moied

Comment 7

16 years ago
cc'ing benc
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P4

Updated

16 years ago
Target Milestone: --- → Future
(Reporter)

Comment 8

16 years ago
This bug seems to have gone (Moz RC1)! Maybe their webserver was fixed? I'll
mark it as INVALID.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.