desktop awesomebar dropdown animation janks after launch

RESOLVED DUPLICATE of bug 1353725

Status

()

RESOLVED DUPLICATE of bug 1353725
a year ago
a year ago

People

(Reporter: bkelly, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qf])

STR:

1. Open a fresh browser instance on a profile with some browsing history
2. Click the dropdown arrow in the awesomebar
3. Notice that the animation visibly janks as the drop down expands

Here is a profile from 55.0a1 (2017-05-17) (64-bit) on windows:

https://perfht.ml/2qscfdG

Its spending:

* 112ms in _onResultRow from UnifiedComplete.js
* Which spends 69ms in _handleOverflow from autocomplete.xml
* Which is all due to getBoundingClientRect trigger sync reflows

My guess is that our history sub-system is adding the entries to the dropdown, but its triggering a recalculation on every entry added.  At startup we may want to do a bulk add and only one recalculation.  This is just a guess, though.
(In reply to Ben Kelly [reviewing, but slowly][:bkelly] from comment #0)
> At
> startup we may want to do a bulk add and only one recalculation.  This is
> just a guess, though.

we can't just do a bulk add because results of a search come ASAP, and asynchronously. Btw, I?ll just dupe this and post the profile to the other bug.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1353725
You need to log in before you can comment on or make changes to this bug.