Text Zoom loses scroll position

VERIFIED DUPLICATE of bug 64926

Status

()

defect
P3
normal
VERIFIED DUPLICATE of bug 64926
17 years ago
17 years ago

People

(Reporter: mjw, Assigned: attinasi)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

17 years ago
Ok; bit of a subjective one this, but here goes.

When viewing a *long* page of text/html, zooming in, say two steps (Cntl++) will
cause you to lose your position down the page. One may have to scroll two or
three pages to refind your position in the text.

HOWTO REPRODUCE / TESTCASE
==========================

1) Go to http://lartc.org/HOWTO//cvs/2.4routing/output/2.4routing-15.html ( it's
a long page).
2) Scroll half way down the page.
3) Highligh a line of text (this is just to mark where you are).
4) Zoom in a few times (Cntl++.
5) Scroll up/down to the line that you highlighted.
6) Notice how far you have to scroll to get back to your original position in
the text.

EXPECTED RESULT
===============
The (highlighed line / line you are viewing) should remain midway down the screen.
-> Layout
Assignee: Matti → attinasi
Component: Browser-General → Layout
QA Contact: imajes-qa → petersen

Comment 2

17 years ago
Changing QA contact
QA Contact: petersen → moied

Comment 3

17 years ago
Using build ID 20020416 on winxp(pro)
http://lartc.org/HOWTO//cvs/2.4routing/output/2.4routing-15.html is not a valid
URL, tried another long page at http://bpdg.blogs.eff.org/
zooming by Cntl++ does resonable zooming

Updated

17 years ago
Severity: minor → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: page midway should not migrate when zooming → zooming loses scroll position

Comment 4

17 years ago
*** Bug 132834 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Summary: zooming loses scroll position → Text Zoom loses scroll position

Comment 5

17 years ago
As bz pointed out in the dup, this might depend on bug 60307, "Images loading
above top of window can cause scrolling up".

See also bug 139832 (for resizing windows), which suggests an approximate method
of getting the right scroll position that involves keeping the scroll percent
rather than the number of pixels.

Updated

17 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 6

17 years ago
*** Bug 163025 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
This seems like a duplicate of Bug 64926

Comment 8

17 years ago

*** This bug has been marked as a duplicate of 64926 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE

Comment 9

17 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.