If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add telemetry for the receiving end of sync IPC messages

RESOLVED DUPLICATE of bug 1365719

Status

()

Core
IPC
RESOLVED DUPLICATE of bug 1365719
4 months ago
4 months ago

People

(Reporter: Ehsan, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

We have IPC_SYNC_MAIN_LATENCY_MS which measures the cost of synchronous messages sent from the parent and child processes, but we currently have no way to know whether these messages took a long time to be processed in their RecvFooBar() handler or on the way to get to the responding thread.

It would be nice to add some telemetry on the receiving end about this, so that we could for example subtract the cost of the receiving end from the cost of the sending end to get an idea of how much of the cost goes towards the overhead of delivering the message vs processing it.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1365719
You need to log in before you can comment on or make changes to this bug.