Closed Bug 1365935 Opened 3 years ago Closed 3 years ago

gfx/webrender_bindings/Moz2DImageRenderer.cpp:17:0: fatal error: ft2build.h: No such file or directory

Categories

(Core :: Graphics: WebRender, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- fixed

People

(Reporter: jbeich, Assigned: lsalzman)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

$ echo "ac_add_options --enable-system-cairo" >>.mozconfig
$ ./mach bootstrap
$ ./mach build
[...]
/usr/bin/clang++ -std=gnu++11 -o Unified_cpp_webrender_bindings0.o -c -Iobjdir/dist/stl_wrappers -Iobjdir/dist/system_wrappers -include config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DMOZ_ENABLE_FREETYPE -DOS_POSIX=1 -DOS_FREEBSD=1 -DOS_BSD=1 -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -Igfx/webrender_bindings -Iobjdir/gfx/webrender_bindings -Iobjdir/ipc/ipdl/_ipdlheaders -Iipc/chromium/src -Iipc/glue -Iobjdir/dist/include  -Iobjdir/dist/include/nspr -Iobjdir/dist/include/nss    -I/usr/local/include/pixman-1   -fPIC  -DMOZILLA_CLIENT -include objdir/mozilla-config.h -MD -MP -MF .deps/Unified_cpp_webrender_bindings0.o.pp -Qunused-arguments    -I/usr/local/include -Qunused-arguments -Wall -Wc++11-compat -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wloop-analysis -Wc++11-compat-pedantic -Wc++14-compat -Wc++14-compat-pedantic -Wc++1z-compat -Wcomma -Wimplicit-fallthrough -Wstring-conversion -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wformat -Wno-gnu-zero-variadic-macro-arguments -Wno-unknown-warning-option -Wno-return-type-c-linkage -fno-exceptions -fno-strict-aliasing -fno-rtti -fno-exceptions -fno-math-errno -pipe  -O -fno-omit-frame-pointer     objdir/gfx/webrender_bindings/Unified_cpp_webrender_bindings0.cpp
In file included from objdir/gfx/webrender_bindings/Unified_cpp_webrender_bindings0.cpp:2:
In file included from gfx/webrender_bindings/Moz2DImageRenderer.cpp:17:
objdir/dist/system_wrappers/ft2build.h:3:15: fatal error:
      'ft2build.h' file not found
#include_next <ft2build.h>
              ^~~~~~~~~~~~
1 error generated.
So, --enable-system-cairo isn't really supported anymore. We've diverged enough from upstream that I don't really trust swapping them.
Comment on attachment 8869026 [details]
Bug 1365935 - Unbreak --enable-system-cairo after bug 1364628.

https://reviewboard.mozilla.org/r/140688/#review144100

This will fix the build but the result will have thread safety issues in the future.
Because this is a solution we may or may not have to use in the future in other places in the code (like OMTP), it probably makes sense to move FT_Library creation into Factory. This way there is no mucking around with moz.builds and CXXFLAGS, since the FT crud is encapsulated.
Attachment #8869088 - Flags: review?(jmuizelaar)
Attachment #8869088 - Flags: review?(jmuizelaar) → review+
Attachment #8869026 - Attachment is obsolete: true
Attachment #8869026 - Flags: review?(mh+mozilla)
Attachment #8869026 - Flags: review?(lsalzman)
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3c508994ee44
add Moz2D Factory methods for making an FT_Library. r=jrmuizel
Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/3c508994ee44
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.