If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Autophone - improve LogDecorator to allow cross branch failure analysis

RESOLVED FIXED

Status

Testing
Autophone
RESOLVED FIXED
4 months ago
4 months ago

People

(Reporter: bc, Assigned: bc)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Assignee)

Description

4 months ago
Created attachment 8869177 [details]
2017-05-failures.txt.bz2

I have been looking into the recent state of affairs with the Autophone unit testing with the goal of filing bugs on the recent spate of regressions however the availability and format of the data makes this more difficult than it should be.

First, the recent change to use a logging server, though with faults of its own, has been a boon since it helps consolidate all logging from all of the workers into the main process' log which can then be analyzed. The new formats are a bit more amenable to parsing using awk as well.

I'm attaching the failures obtained from the logs since ~2017-05-10 which is very promising but highlights a failure in the data. There is no indication of which branch/repository the failure occurred upon which makes the logs useless for the intended purpose. This text file is 74K bzip2ed though about 30M uncompressed.

It is a very simple change to incorporate the repo into the log output via the Log Decorators and I'd like to make this change now so I can get good data for bug filing.
(Assignee)

Comment 1

4 months ago
Created attachment 8869502 [details] [diff] [review]
bug-1366055-logdeco-v1.patch

adds repo, phone sdk, platform to the decorator
Attachment #8869502 - Flags: review?(jmaher)
(Assignee)

Comment 2

4 months ago
Created attachment 8869503 [details] [diff] [review]
bug-1366055-errors-v1.patch

adds errors.sh and errors.awk to analyze the logs.
Attachment #8869503 - Flags: review?(jmaher)
(Assignee)

Comment 3

4 months ago
Created attachment 8869504 [details]
failures.txt.bz2

example bzip2ed failures.txt output from my recent local tests.
Comment on attachment 8869502 [details] [diff] [review]
bug-1366055-logdeco-v1.patch

Review of attachment 8869502 [details] [diff] [review]:
-----------------------------------------------------------------

nice and easy to review
Attachment #8869502 - Flags: review?(jmaher) → review+
Comment on attachment 8869503 [details] [diff] [review]
bug-1366055-errors-v1.patch

lets do the rubber stamp thing
Attachment #8869503 - Flags: review?(jmaher) → review+
(Assignee)

Comment 6

4 months ago
https://github.com/mozilla/autophone/commit/a6c4b1e35f32e4287a57a21827c950ccf50349d0
https://github.com/mozilla/autophone/commit/9f45e6c06825fd5b514a6b6e4002b155c4cdc466
deployed 2017-05-19 21:15
Blocks: 1157427
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.