Closed Bug 1366070 Opened 2 years ago Closed 2 years ago

Devedition uses the same Balrog blob names as Beta

Categories

(Release Engineering :: Release Automation: Other, enhancement, P1, major)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rail, Assigned: rail)

References

Details

Attachments

(3 files)

Blocks: 1353825
I'm testing the following approach now: https://hg.mozilla.org/projects/jamun/rev/d2e96d9498f93ada6b51020734ebd18269beb5cf and a release runner hack:

diff --git a/buildfarm/release/release-runner.py b/buildfarm/release/release-runner.py
--- a/buildfarm/release/release-runner.py
+++ b/buildfarm/release/release-runner.py
@@ -499,7 +499,7 @@ def main(options):
                 "eme_free_repacks_platforms": branchConfig.get("eme_free_repacks_platforms", {}).get(release["product"], []),
                 "sha1_repacks_platforms": branchConfig.get("sha1_repacks_platforms", []),
                 "l10n_changesets": release['l10n_changesets'],
-                "extra_balrog_submitter_params": extra_balrog_submitter_params,
+                "extra_balrog_submitter_params": extra_balrog_submitter_params + " --product " + release["product"],
                 "publish_to_balrog_channels": publish_to_balrog_channels,
                 "snap_enabled": branchConfig.get("snap_enabled", {}).get(release["product"], False),
                 "update_verify_channel": branchConfig.get("update_verify_channel", {}).get(release["product"]),
With some little tweak (below) the tasks look better:

2017-05-19 16:46:55,593 - DEBUG - Balrog request to https://balrog-admin.stage.mozaws.net/api/releases/devedition-54.0b7-build10

They fail because we have some issues with routing: https://public-artifacts.taskcluster.net/7zJU3mCCQU2y8Zsi59aeGg/0/public/logs/live_backing.log

diff --git a/buildfarm/release/release-runner.py b/buildfarm/release/release-runner.py
--- a/buildfarm/release/release-runner.py
+++ b/buildfarm/release/release-runner.py
@@ -334,7 +334,7 @@ def main(options):
     retrying_tc_config.update({"maxRetries": 12})
     balrog_username = config['balrog'].get("username")
     balrog_password = config["balrog"].get("password")
-    extra_balrog_submitter_params = config["balrog"].get("extra_balrog_submitter_params")
+    extra_balrog_submitter_params = config["balrog"].get("extra_balrog_submitter_params", "")
     beetmover_aws_access_key_id = config["beetmover"].get("aws_access_key_id")
     beetmover_aws_secret_access_key = config["beetmover"].get("aws_secret_access_key")
     gpg_key_path = config["signing"].get("gpg_key_path")
Assignee: nobody → jlorenzo
I'm looking at the routing issues.
We're able to ping the machine but not able to establish an HTTPS connection to it[1]. OSI layers from 1 to 3 are fine. Either the TCP or the HTTP layer are causing problems

This can either mean:
a. Port 443 is not open for us. A firewall might block us.
b. Or he http server is simply not up.

[1] https://public-artifacts.taskcluster.net/Gvkq1BLURKSuHMqBkoaiUw/0/public/logs/live_backing.log
It looks like we're firewall'd[1]:
> $ nc -vz balrog-admin.stage.mozaws.net 443
> ec2-52-71-237-144.compute-1.amazonaws.com [52.71.237.144] 443 (?) : Connection timed out

When I run the same command on my machine, I see the port 443 being open.

[1] https://public-artifacts.taskcluster.net/Gvkq1BLURKSuHMqBkoaiUw/0/public/logs/live_backing.log
Bug 1366764 was filed to track the firewall problem.
Rail told me balrogVpnProxy doesn't support the staging instance yet. This means the problem isn't on the firewall side. He added he wanted to try to spin a disposable balrog instance, outside of the staging VPN.
Assignee: jlorenzo → rail
Comment on attachment 8870456 [details]
Bug 1366070 - Temp Balrog instance for jamun

https://reviewboard.mozilla.org/r/141892/#review145548
Attachment #8870456 - Flags: review?(bhearsum) → review+
Comment on attachment 8870490 [details]
Bug 1366070 - Pass --product to Balrog submitters

https://reviewboard.mozilla.org/r/141922/#review145624

::: buildfarm/release/release-runner.py:503
(Diff revision 1)
>                  "beetmover_candidates_bucket": branchConfig["beetmover_buckets"][release["product"]],
>                  "partner_repacks_platforms": branchConfig.get("partner_repacks_platforms", {}).get(release["product"], []),
>                  "eme_free_repacks_platforms": branchConfig.get("eme_free_repacks_platforms", {}).get(release["product"], []),
>                  "sha1_repacks_platforms": branchConfig.get("sha1_repacks_platforms", []),
>                  "l10n_changesets": release['l10n_changesets'],
> -                "extra_balrog_submitter_params": extra_balrog_submitter_params,
> +                "extra_balrog_submitter_params": extra_balrog_submitter_params + " --product " + release["product"].capitalize(),

DevEdition would be better than Devedition, but meh, either is fine for Balrog release names.
Attachment #8870490 - Flags: review?(bhearsum) → review+
Comment on attachment 8870489 [details]
Bug 1366070 - Override product name in Balrog submission.  a=release DONTBUILD

https://reviewboard.mozilla.org/r/141918/#review145626
Attachment #8870489 - Flags: review?(bhearsum) → review+
(In reply to Ben Hearsum (:bhearsum) from comment #17) 
> DevEdition would be better than Devedition, but meh, either is fine for
> Balrog release names.

I thought about that, but that would require to have a product->product_pretty_name mapping and use it in multiple places. I'm not sure I want to implement that. ;)
Keywords: leave-open
Pushed by raliiev@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bb3f1daba7d9
Override product name in Balrog submission. r=bhearsum a=release DONTBUILD
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/projects/cedar/rev/bb3f1daba7d9fdb049fafd3ca4e7cb5318503d38
Bug 1366070 - Override product name in Balrog submission. r=bhearsum a=release DONTBUILD
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.