Consider running Speedometer v2 in PGO workload

RESOLVED DUPLICATE of bug 1356652

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 1356652
a year ago
3 months ago

People

(Reporter: till, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qf])

(Reporter)

Description

a year ago
We're running SunSpider in the PGO workload right now. Not sure what else, perhaps Octane or some ancient version of the v8 benchmark? In any case, it'd be good to run something more specifically designed to reflect modern JS code as found on the web, such as Speedometer v2.

The benchmark runs for quite some time, so perhaps making it faster, e.g. by reducing iterations, would be in order.
Our current PGO workload is defined in the build/pgo directory. Start at index.html then follow the links to referenced files.

It should be relatively low effort to add new things, push to try, and compare results. If you can move the performance needle, it will be hard for us to say no to any changes. That being said, we would appreciate if the profile phase were as quick as possible. I think it is currently hovering around 90s.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1356652

Updated

3 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.