Closed Bug 1366573 Opened 2 years ago Closed 2 years ago

Page action button looks almost vanished on mousehover

Categories

(Firefox :: Theme, defect, P1, minor)

55 Branch
x86_64
Linux
defect

Tracking

()

VERIFIED FIXED
Firefox 55
Iteration:
55.7 - Jun 12
Tracking Status
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- verified

People

(Reporter: euthanasia_waltz, Assigned: Gijs)

References

Details

(Whiteboard: [photon-structure])

Attachments

(2 files)

Page action button becomes almost invisible when mouse hover on the button in Compact Dark theme.
It's fine on Win 7.
We won't ship the Photon changes for 55 so this doesn't need to track.

Dão, you run Linux, can you reproduce this? Any idea what's going on? I'm a bit lost - aren't we using an svg with context-fill, which should still be white in the dark theme? Or did that change somehow?
Flags: needinfo?(dao+bmo)
(In reply to :Gijs from comment #2)
> We won't ship the Photon changes for 55 so this doesn't need to track.
> 
> Dão, you run Linux, can you reproduce this?

Yep.

> Any idea what's going on? I'm a
> bit lost - aren't we using an svg with context-fill, which should still be
> white in the dark theme? Or did that change somehow?

Looks like this is changing the color on hover: http://searchfox.org/mozilla-central/rev/2933592c4a01b634ab53315ce2d0e43fccb82181/toolkit/themes/linux/global/toolbarbutton.css#40-42

You'll probably need to explicitly set the color to inherit.
Flags: needinfo?(dao+bmo)
Whiteboard: [photon-structure][triage]
Flags: qe-verify?
Priority: -- → P2
Whiteboard: [photon-structure][triage] → [photon-structure]
Assignee: nobody → gijskruitbosch+bugs
Status: UNCONFIRMED → ASSIGNED
Iteration: --- → 55.7 - Jun 12
Ever confirmed: true
Priority: P2 → P1
Comment on attachment 8875727 [details]
Bug 1366573 - force foreground color inheritance on page action button,

https://reviewboard.mozilla.org/r/147150/#review151322
Attachment #8875727 - Flags: review?(dao+bmo) → review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/3952f89f9b1d
force foreground color inheritance on page action button, r=dao
https://hg.mozilla.org/mozilla-central/rev/3952f89f9b1d
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
I have reproduced this bug with Nightly 55.0a1 (2017-05-21) in Deepin OS (64-bit).

This bug's fix is verified with latest Nightly 55.0a1 (64-bit).
 
Build ID   :    20170611100318
User Agent :	Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0

[bugday-20170607]
Status: RESOLVED → VERIFIED
Flags: qe-verify?
Blocks: 1387512
You need to log in before you can comment on or make changes to this bug.