Closed Bug 1366684 Opened 4 years ago Closed 4 years ago

Alt+Shift+1 doesn't work for manifest.json commands

Categories

(WebExtensions :: Untriaged, defect)

53 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1337545

People

(Reporter: mrsamueljun, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36

Steps to reproduce:

I'm trying to trigger a command on `Alt+Shift+1` but the key combination isn't triggering at all.

```
  "commands": {
    "start-tomato": {
      "suggested_key": {
        "default": "Alt+Shift+1"
      },
      "description": "Start a new tomato timer."
    }
  }
```

The commands are there and returning correctly when I `console.log`. These two commands both return the expected results:

```
browser.commands.getAll().then(commands => console.log(commands));
console.log(browser.commands.onCommand.hasListener('start-tomato');
```

I know that my code is working correctly becasue `Alt+1` and `Alt+Shift+S` both work properly. This is occurring on both Mac and Linux. I'm wondering if there is another competing key combination. If there is, then there is a problem in the documentation here: https://developer.mozilla.org/en-US/Add-ons/WebExtensions/manifest.json/commands as well as no console errors in the about:debugging window.


Actual results:

The commands aren't triggered when I press the key combination.


Expected results:

The commands should trigger when I press the key combination.
I should also mention that the key combination works just fine on Chrome.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1337545
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.