Two search fields are displayed on the new debugger

VERIFIED FIXED in Firefox 56

Status

P1
normal
VERIFIED FIXED
a year ago
4 months ago

People

(Reporter: hani.yacoub, Assigned: jlast)

Tracking

55 Branch
Firefox 56

Firefox Tracking Flags

(firefox53 unaffected, firefox54 unaffected, firefox55 disabled, firefox56 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8870059 [details]
Recording #7.mp4

[Affected versions]: 
Nightly 55.0a1

[Affected platforms]:
Platforms: Windows 10 x 64, Ubuntu 16.10 and Mac OS X 10.12

[Steps to reproduce]:
1. Go to https://devtools-html.github.io/debugger-examples/examples/todomvc/
2. Open Debugger.
3. From "Sources" section select a file that has the ".js" termination (e.g todo-view.js).
4. (On Windows - Press CTRL + F OR on Mac - Press CMD + F )
   Search for a term that can be found (e.g listenTo).
5. Click on any code line.
6. Press (On Windows - Press CTRL + F OR on Mac - Press CMD + F )

[Expected result]:
Pressing (On Windows - Press CTRL + F OR on Mac - Press CMD + F) should highlight or close the search field.

[Actual result]:
Two search fields are displayed on the new debugger
(Reporter)

Updated

a year ago
Blocks: 1294139
status-firefox53: --- → unaffected
status-firefox54: --- → unaffected
status-firefox55: --- → affected
(Assignee)

Updated

a year ago
Priority: -- → P1
Fixed here: https://github.com/devtools-html/debugger.html/pull/3135
And cannot be reproduced: https://github.com/devtools-html/debugger.html/issues/3006#issuecomment-309403791
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Reporter)

Comment 3

a year ago
I verified this bug on Mac OS 12.12 and it is fixed, but it's still reproducible on Windows 10 x 64 and Ubuntu 16.04 x64.
Flags: needinfo?(jlaster)
Flags: needinfo?(clarkbw)
Ok, lets have Jason take a look at this on Windows only.  Thanks!
Flags: needinfo?(clarkbw)
(Assignee)

Comment 5

a year ago
Thanks. I'll take a look
Flags: needinfo?(jlaster)
(Assignee)

Comment 6

a year ago
This was fixed on nightly last week. I tested it today on a windows laptop and could not reproduce.
(Reporter)

Comment 7

a year ago
Build ID: 20170706060058
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Verified as fixed on Firefox Nightly 56.0a1 on Windows 10 x 64, Windows 7 x32, Mac OS X 10.12 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
status-firefox56: --- → verified
the new debugger is disabled in 55.
status-firefox55: affected → disabled
Assignee: nobody → jlaster
Target Milestone: --- → Firefox 56

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.