Closed Bug 1366891 Opened 3 years ago Closed 2 years ago

Handle deduped child IDs when reordering folder children

Categories

(Firefox :: Sync, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1305563

People

(Reporter: Lina, Unassigned)

References

Details

When we dedupe a bookmark, we don't update its GUID in the `children` array of its containing folder. This means that we might get the child order wrong if we dupe a NORMAL bookmark to another NORMAL bookmark, and that bookmark appears in a folder that we added to `_childrenToOrder`.

I think we could also work around this if we never duped NORMAL to NORMAL (bug 1366888).
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1305563
You need to log in before you can comment on or make changes to this bug.