Closed Bug 1367049 Opened 6 years ago Closed 6 years ago

Voice chat on Discord is stuck on RTC Connecting, regression


(Web Compatibility :: Desktop, defect, P1)

Firefox 55


(firefox53 unaffected, firefox54 unaffected, firefox55+ fixed)

Tracking Status
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 + fixed


(Reporter: myuumyuutsu, Unassigned)



(Keywords: regression, Whiteboard: [sitewait])


(1 file)

Attached image annoying.png
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170523030206

Steps to reproduce:

Go to Discord and join channel with Voice chat for example and then connect to voice chat

Also this started happening from this build but I don't really know how to use Mozregression so it could be false

Actual results:

After connecting it gets stuck on RTC Connecting

Expected results:

It should have connected fully
I just tried on my regular nightly and I saw the same issue, but when I tried on a fresh nightly profile, it works correccttly.
Can you check on a new fresh profile?
Flags: needinfo?(myuumyuutsu)
Component: Untriaged → WebRTC: Networking
Product: Firefox → Core
Tried to use two new profiles on one of which I used my account and the other one where I used unclaimed account, both are stuck in the same way.
Regression range:

Nils Ohlmeier [:drno] — Bug 1323723: reject setup value actpass in answers. r=bwc
Nils Ohlmeier [:drno] — Bug 1323723: enforce a=setup in SDP offers. r=bwc
Blocks: 1323723
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
Flags: needinfo?(myuumyuutsu) → needinfo?(drno)
Keywords: regression
P1 until we learn if this is a site bug.
Rank: 15
Priority: -- → P1
After Firefox creating the offer with 'a=setup:actpass' the SDP answer from the Discord server contains 'a=setup:actpass'. This is clearly not spec compliant. Older versions of Firefox used to ignore this. The answerer has to choose either 'a=setup:active' or 'a=setup:passive', where active is the recommended role as per spec.
Closed: 6 years ago
Flags: needinfo?(drno)
Resolution: --- → INVALID
I'll reopen this bug and change it to TE because Discord is an important VoIP application used by many gamers worldwide. We need to contact Discord and be sure they fix the issue on their side before the release of FF55.
Component: WebRTC: Networking → Desktop
Product: Core → Tech Evangelism
Resolution: INVALID → ---
Version: 55 Branch → Firefox 55
Adam, can you try to get us in touch with Discord? See Comment #5 for an explanation of what they need to change their SDP answer to -- thanks!
Flags: needinfo?(astevenson)
Whiteboard: [needscontact]
Trying to reach Jesse Howarth on Twitter:
Flags: needinfo?(astevenson)
Whiteboard: [needscontact] → [sitewait]
We got a quick response: "we're aware of it and planning on fixing the bug before Firefox 55 releases."
I have no idea how important Discord is. Is it worth adding them to our manual test cycles, or do we have close enough contacts with them to talk to them about their testing (because looking at their signaling I would expect a lot more problems in the future)?
(In reply to Nils Ohlmeier [:drno] from comment #10)
> I have no idea how important Discord is. 
Some numbers in this recent aricle:

This service is really popular in gaming communities in US/Canada and Europe.
I agree it's very popular (I use it too).

Discord's website is also ranked 109 in U.S by Alexa. That said, it's not clear how much voice chat usage happens through web vs. apps.

We can try to discuss further with them if we think it's valuable.
Let's track this for 55 to make sure it gets resolved.
Adam, can you test if this is still an issue?
Flags: needinfo?(astevenson)
Seems like this is fixed. I get to "Voice Connected" in both Firefox 55 and 56 for OSX.

Let's close this report, thanks everyone!
Closed: 6 years ago6 years ago
Flags: needinfo?(astevenson)
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility

I observed this in FF 76 on May 10.

Thanks! Discord has fixed and should be pushing out the update soon.

Hi, I'm encountering this issue again.
I'm using firefox 85.0.2 (64-bit) on archlinux with pulseaudio as sound server.
I was in a discord call, with everything working just fine; I disconnected, reconnected, and then suddenly it was stuck on "RTC Connecting". The following didn't help:

  • rebooting my computer
  • clearing all cookies and local data
  • using a different firefox profile
  • trying without my VPN
  • rebooting my router
  • stopping and uninstalling pulseaudio
  • trying out different servers than Europe (my default)

Voice chat works just fine on the discord desktop app, however.

Oops, nevermind, the following fixed it:
Going into my discord voice settings and using the "Reset Voice Settings" button.
Sorry about the message.

You need to log in before you can comment on or make changes to this bug.