Closed Bug 1367194 Opened 2 years ago Closed 2 years ago

Intermittent toolkit/content/tests/widgets/test_videocontrols.html | ----- test #34 ----- - Result logged after SimpleTest.finish()

Categories

(Toolkit :: Video/Audio Controls, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: ralin)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

ah, I guess we need to explicitly pause the video at the end to prevent "pause" event.
Assignee: nobody → ralin
Status: NEW → ASSIGNED
Comment on attachment 8870682 [details]
Bug 1367194 - Explicitly pause video at the end of the test to prevent the media backend from pausing the video as the page closes and thus

https://reviewboard.mozilla.org/r/142150/#review146020

::: commit-message-96e18:1
(Diff revision 1)
> +Bug 1367194 - Intermittent toolkit/content/tests/widgets/test_videocontrols.html | ----- test #34 ----- - Result logged after SimpleTest.finish(): explicitly pause video at the end. r=jaws

This commit message needs to be changed since it doesn't really explain anything about why this change is necessary.
Attachment #8870682 - Flags: review?(jaws) → review-
Comment on attachment 8870682 [details]
Bug 1367194 - Explicitly pause video at the end of the test to prevent the media backend from pausing the video as the page closes and thus

https://reviewboard.mozilla.org/r/142150/#review146022

You could remove everything at the beginning. Maybe write:
Bug 1367194 - Explicitly pause video at the end of the test to prevent the media backend from pausing the video as the page closes and thus randomly firing a 'pause' event when the test isn't expecting it. r=jaws

r=me with that change
Attachment #8870682 - Flags: review- → review+
I initially thought that is the naming convention of intermittent bug :P 

I've changed the commit message, thank you Jared,
Keywords: checkin-needed
Autoland can't push this until all pending issues are marked as resolved in MozReview.
Keywords: checkin-needed
Sorry. The issue is resolved.
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/40bd5b696029
Explicitly pause video at the end of the test to prevent the media backend from pausing the video as the page closes and thus r=jaws
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/40bd5b696029
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Comment on attachment 8870682 [details]
Bug 1367194 - Explicitly pause video at the end of the test to prevent the media backend from pausing the video as the page closes and thus

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1352724
[User impact if declined]: its a followup of Bug 1352724 as an intermittent fix
[Is this code covered by automated tests?]: no need
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: uplift this after Bug 1352724's uplift request is done
[Is the change risky?]: no
[Why is the change risky/not risky?]: fix intermittent only
[String changes made/needed]: none

Thanks :)
Attachment #8870682 - Flags: approval-mozilla-beta?
Comment on attachment 8870682 [details]
Bug 1367194 - Explicitly pause video at the end of the test to prevent the media backend from pausing the video as the page closes and thus

see bug 1352724 comment 27.
Attachment #8870682 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
You need to log in before you can comment on or make changes to this bug.