stylo: translate + rotate does not work as expected

RESOLVED DUPLICATE of bug 1335998

Status

()

RESOLVED DUPLICATE of bug 1335998
a year ago
a year ago

People

(Reporter: shinglyu, Unassigned)

Tracking

(Blocks: 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
STR:

* Open https://tympanus.net/Tutorials/OriginalHoverEffects/index3.html
* Hover any of the image

Expected:

* A semi-transparent mask will rotate in

Actual:

* The mask just appears without the rotate animation

Version:
* commit 20ab6785cbd9da0af89da357cbef4f50c6a2afdf
* linux64 opt build
Blocking css animation bug not to be missed this.  The animation might be a transition though, anyway.
Blocks: 1288269
I see an odd result. Incoming rotate does not work, but going back rotate seems to work fine.
Looks like a dupe of bug 1365851. We animate from 'translate(0px, 0px)' to 'translate(460px, -100px) rotate(180deg)'.
Oh, nice. It's just a transform list.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1335998
You need to log in before you can comment on or make changes to this bug.