Crash in java.lang.NullPointerException: Attempt to invoke interface method ''void org.mozilla.gecko.media.ICodecCallbacks.onError(boolean)'' on a null object reference at org.mozilla.gecko.media.Codec.reportError(Codec.java)

RESOLVED FIXED in Firefox 55

Status

()

defect
P1
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jujjyl, Assigned: jhlin)

Tracking

({crash})

unspecified
Firefox 55
Points:
---

Firefox Tracking Flags

(firefox53 unaffected, firefox54 unaffected, firefox55 fixed)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-0442d85b-c67e-4305-b413-3781a0170522.
=============================================================
(Reporter)

Comment 1

2 years ago
STR: http://clb.demon.fi/t/2017-05-16-SkiSafari/

Crashes on the following tested devices:

 - Google Pixel XL - Android 7.1.2, Kernel 3.18.31-g416bf43 (marlin N2G47O), Fennec 55.0a1 (2017-05-19) - Qualcomm Adreno 530, OpenGL ES 3.2 V@145.0 (GIT@Idb2b4cb785)

 - Samsung Galaxy S7 Edge SM-G935F - Android 7.0, Kernel 3.18.14-11104523 (NRD90M), Fennec 55.0a1 (2017-05-19), ARM Mali-T880, OpenGL ES 3.2 v1.r12p1-03dev0.228ab63cced004f840e7dd47b762a1d0

 - Huawei P10 Plus - Android 7.0, Kernel 4.1.18-gfd75bbb (VKY-L29), Fennec 55.0a1 (2017-05-19) - ARM Mali-G71, OpenGL ES 3.2 v1.r2p0-02dev0.f7269486f3e0e3b308edf85872e361f4
(Assignee)

Updated

2 years ago
Assignee: nobody → jolin
Priority: -- → P1
Comment hidden (mozreview-request)

Comment 3

2 years ago
mozreview-review
Comment on attachment 8872883 [details]
Bug 1367367 - handle exception caused by late error callbacks.

https://reviewboard.mozilla.org/r/144396/#review148328
Attachment #8872883 - Flags: review?(esawin) → review+

Comment 4

2 years ago
Pushed by jolin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5a37485d488d
handle exception caused by late error callbacks. r=esawin

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/5a37485d488d
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
You need to log in before you can comment on or make changes to this bug.