Closed Bug 1367628 Opened 3 years ago Closed 3 years ago

Entire browsing area for all tabs permanently turns black or white (on Nvidia GPUs)

Categories

(Core :: Graphics, defect)

53 Branch
All
Windows 10
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 1163440
Tracking Status
firefox53 + affected
firefox54 - ?
firefox55 + ?

People

(Reporter: elias4444, Unassigned)

Details

(Whiteboard: gfx-noted)

Attachments

(4 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170518000419

Steps to reproduce:

While browsing (mostly when watching video, though not always).


Actual results:

The entire browser content area (below the URL bar) turns entirely black. If I was watching a youtube video, the only visible object is the red and gray timeline of the youtube video. All other open tabs also turn black.


Expected results:

Page should have stayed the way it was, without turning all black.
System is Windows 10 Pro, Nvidia 970, 16gb ram, Skylake processor (i5). Nvidia drivers are the latest (382.05). I have tried a clean installation of the drivers, as well as a clean install of both Firefox 32-bit and Firefox 64-bit. Problem persists.
I looked up drivers and it seems that that version (382.05) is from May 04, 2017, but there is a newer one available (382.33) May 22, 2017. (admittedly brand new)
http://www.geforce.com/drivers/results/119399

Best to test that out.
Reporter, could you attach the info of about:support(type in URL box) page?
(In reply to Peter Chang[:pchang] from comment #3)
> Reporter, could you attach the info of about:support(type in URL box) page?

Application Basics
------------------

Name: Firefox
Version: 53.0.3
Build ID: 20170518000419
Update Channel: release
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
OS: Windows_NT 10.0
Multiprocess Windows: 1/1 (Enabled by default)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Application Update Service Helper
Version: 2.0
Enabled: true
ID: aushelper@mozilla.org

Name: Multi-process staged rollout
Version: 1.14
Enabled: true
ID: e10srollout@mozilla.org

Name: Pocket
Version: 1.0.5
Enabled: true
ID: firefox@getpocket.com

Name: Shield Recipe Client
Version: 1.0.0
Enabled: true
ID: shield-recipe-client@mozilla.org

Name: uBlock Origin
Version: 1.12.4
Enabled: true
ID: uBlock0@raymondhill.net

Name: Web Compat
Version: 1.0
Enabled: true
ID: webcompat@mozilla.org

Graphics
--------

Features
Compositing: Direct3D 11
Asynchronous Pan/Zoom: wheel input enabled
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 970 Direct3D11 vs_5_0 ps_5_0)
WebGL2 Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 970 Direct3D11 vs_5_0 ps_5_0)
Audio Backend: wasapi
Direct2D: true
DirectWrite: true (10.0.15063.0)
GPU #1
Active: Yes
Description: NVIDIA GeForce GTX 970
Vendor ID: 0x10de
Device ID: 0x13c2
Driver Version: 22.21.13.8205
Driver Date: 5-1-2017
Drivers: C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_a2b0acab06663645\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_a2b0acab06663645\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_a2b0acab06663645\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_a2b0acab06663645\nvldumdx.dll C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_a2b0acab06663645\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_a2b0acab06663645\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_a2b0acab06663645\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_a2b0acab06663645\nvldumd.dll
Subsys ID: 31601462
RAM: 4096

Diagnostics
ClearType Parameters: Gamma: 2.2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 100
AzureCanvasAccelerated: 0
AzureCanvasBackend: Direct2D 1.1
AzureCanvasBackend (UI Process): skia
AzureContentBackend: Direct2D 1.1
AzureContentBackend (UI Process): skia
AzureFallbackCanvasBackend (UI Process): cairo
ClearType Parameters: Gamma: 2.2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 100
Decision Log
D3D9_COMPOSITING:
disabled by default: Disabled by default




Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 2
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 8
browser.search.useDBForOrder: true
browser.sessionstore.upgradeBackup.latestBuildID: 20170518000419
browser.startup.homepage_override.buildID: 20170518000419
browser.startup.homepage_override.mstone: 53.0.3
browser.tabs.remote.autostart.2: true
browser.urlbar.daysBeforeHidingSuggestionsPrompt: 0
browser.urlbar.lastSuggestionsPromptDate: 20160807
dom.apps.lastUpdate.buildID: 20161019084923
dom.apps.lastUpdate.mstone: 49.0.2
dom.apps.reset-permissions: true
dom.mozApps.used: true
dom.push.userAgentID: c81ff6c84c43491498f9b7cef9357238
extensions.lastAppVersion: 53.0.3
font.internaluseonly.changed: true
gfx.crash-guard.d3d11layers.appVersion: 52.0.2
gfx.crash-guard.d3d11layers.deviceID: 0x13c2
gfx.crash-guard.d3d11layers.driverVersion: 21.21.13.7653
gfx.crash-guard.d3d11layers.feature-d2d: true
gfx.crash-guard.d3d11layers.feature-d3d11: true
gfx.crash-guard.status.: 2
gfx.crash-guard.status.d3d11layers: 2
gfx.crash-guard.status.d3d11video: 2
gfx.crash-guard.status.d3d9video: 2
media.benchmark.vp9.fps: 164
media.benchmark.vp9.versioncheck: 2
media.gmp-eme-adobe.abi: x86-msvc-x64
media.gmp-eme-adobe.lastUpdate: 1466612130
media.gmp-eme-adobe.version: 17
media.gmp-gmpopenh264.abi: x86_64-msvc-x64
media.gmp-gmpopenh264.lastUpdate: 1495318973
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20170518000419
media.gmp-manager.lastCheck: 1495634991
media.gmp-widevinecdm.abi: x86_64-msvc-x64
media.gmp-widevinecdm.lastUpdate: 1495318974
media.gmp-widevinecdm.version: 1.4.8.903
media.gmp.storage.version.observed: 1
media.hardware-video-decoding.failed: false
media.webrtc.debug.log_file: C:\Users\jack\AppData\Local\Temp\WebRTC.log
network.cookie.prefsMigrated: true
network.dns.disablePrefetch: true
network.http.speculative-parallel-limit: 0
network.predictor.cleaned-up: true
network.prefetch-next: false
places.database.lastMaintenance: 1495563219
places.history.expiration.transient_current_max_pages: 122334
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.npvlc: 0
print.printer_Canon_MX920_series_Printer_WS.print_bgcolor: false
print.printer_Canon_MX920_series_Printer_WS.print_bgimages: false
print.printer_Canon_MX920_series_Printer_WS.print_duplex: -437918235
print.printer_Canon_MX920_series_Printer_WS.print_edge_bottom: 0
print.printer_Canon_MX920_series_Printer_WS.print_edge_left: 0
print.printer_Canon_MX920_series_Printer_WS.print_edge_right: 0
print.printer_Canon_MX920_series_Printer_WS.print_edge_top: 0
print.printer_Canon_MX920_series_Printer_WS.print_evenpages: true
print.printer_Canon_MX920_series_Printer_WS.print_footercenter:
print.printer_Canon_MX920_series_Printer_WS.print_footerleft: &PT
print.printer_Canon_MX920_series_Printer_WS.print_footerright: &D
print.printer_Canon_MX920_series_Printer_WS.print_headercenter:
print.printer_Canon_MX920_series_Printer_WS.print_headerleft: &T
print.printer_Canon_MX920_series_Printer_WS.print_headerright: &U
print.printer_Canon_MX920_series_Printer_WS.print_in_color: true
print.printer_Canon_MX920_series_Printer_WS.print_margin_bottom: 0.5
print.printer_Canon_MX920_series_Printer_WS.print_margin_left: 0.5
print.printer_Canon_MX920_series_Printer_WS.print_margin_right: 0.5
print.printer_Canon_MX920_series_Printer_WS.print_margin_top: 0.5
print.printer_Canon_MX920_series_Printer_WS.print_oddpages: true
print.printer_Canon_MX920_series_Printer_WS.print_orientation: 0
print.printer_Canon_MX920_series_Printer_WS.print_page_delay: 50
print.printer_Canon_MX920_series_Printer_WS.print_paper_data: 1
print.printer_Canon_MX920_series_Printer_WS.print_paper_height: -1.00
print.printer_Canon_MX920_series_Printer_WS.print_paper_name:
print.printer_Canon_MX920_series_Printer_WS.print_paper_size_unit: 0
print.printer_Canon_MX920_series_Printer_WS.print_paper_width: -1.00
print.printer_Canon_MX920_series_Printer_WS.print_resolution: 600
print.printer_Canon_MX920_series_Printer_WS.print_reversed: false
print.printer_Canon_MX920_series_Printer_WS.print_scaling: 1.00
print.printer_Canon_MX920_series_Printer_WS.print_shrink_to_fit: true
print.printer_Canon_MX920_series_Printer_WS.print_to_file: false
print.printer_Canon_MX920_series_Printer_WS.print_unwriteable_margin_bottom: 0
print.printer_Canon_MX920_series_Printer_WS.print_unwriteable_margin_left: 0
print.printer_Canon_MX920_series_Printer_WS.print_unwriteable_margin_right: 0
print.printer_Canon_MX920_series_Printer_WS.print_unwriteable_margin_top: 0
print.printer_Microsoft_Print_to_PDF.print_bgcolor: false
print.printer_Microsoft_Print_to_PDF.print_bgimages: false
print.printer_Microsoft_Print_to_PDF.print_duplex: -437918235
print.printer_Microsoft_Print_to_PDF.print_edge_bottom: 0
print.printer_Microsoft_Print_to_PDF.print_edge_left: 0
print.printer_Microsoft_Print_to_PDF.print_edge_right: 0
print.printer_Microsoft_Print_to_PDF.print_edge_top: 0
print.printer_Microsoft_Print_to_PDF.print_evenpages: true
print.printer_Microsoft_Print_to_PDF.print_footercenter:
print.printer_Microsoft_Print_to_PDF.print_footerleft: &PT
print.printer_Microsoft_Print_to_PDF.print_footerright: &D
print.printer_Microsoft_Print_to_PDF.print_headercenter:
print.printer_Microsoft_Print_to_PDF.print_headerleft: &T
print.printer_Microsoft_Print_to_PDF.print_headerright: &U
print.printer_Microsoft_Print_to_PDF.print_in_color: true
print.printer_Microsoft_Print_to_PDF.print_margin_bottom: 0.5
print.printer_Microsoft_Print_to_PDF.print_margin_left: 0.5
print.printer_Microsoft_Print_to_PDF.print_margin_right: 0.5
print.printer_Microsoft_Print_to_PDF.print_margin_top: 0.5
print.printer_Microsoft_Print_to_PDF.print_oddpages: true
print.printer_Microsoft_Print_to_PDF.print_orientation: 0
print.printer_Microsoft_Print_to_PDF.print_page_delay: 50
print.printer_Microsoft_Print_to_PDF.print_paper_data: 1
print.printer_Microsoft_Print_to_PDF.print_paper_height: -1.00
print.printer_Microsoft_Print_to_PDF.print_paper_name:
print.printer_Microsoft_Print_to_PDF.print_paper_size_unit: 0
print.printer_Microsoft_Print_to_PDF.print_paper_width: -1.00
print.printer_Microsoft_Print_to_PDF.print_resolution: 600
print.printer_Microsoft_Print_to_PDF.print_reversed: false
print.printer_Microsoft_Print_to_PDF.print_scaling: 1.00
print.printer_Microsoft_Print_to_PDF.print_shrink_to_fit: true
print.printer_Microsoft_Print_to_PDF.print_to_file: false
print.printer_Microsoft_Print_to_PDF.print_unwriteable_margin_bottom: 0
print.printer_Microsoft_Print_to_PDF.print_unwriteable_margin_left: 0
print.printer_Microsoft_Print_to_PDF.print_unwriteable_margin_right: 0
print.printer_Microsoft_Print_to_PDF.print_unwriteable_margin_top: 0
security.sandbox.content.tempDirSuffix: {6b9012bd-08df-40a1-82af-6601fae98127}
services.sync.declinedEngines: forms,passwords,adblockplus,addons,prefs,tabs,history
services.sync.engine.addons: false
services.sync.engine.history: false
services.sync.engine.passwords: false
services.sync.engine.prefs: false
services.sync.engine.prefs.modified: false
services.sync.engine.tabs: false
services.sync.lastPing: 1495660439
services.sync.lastSync: Thu May 25 2017 07:06:07 GMT-0700 (Pacific Standard Time)
services.sync.numClients: 2
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1493164193
ui.osk.debug.keyboardDisplayReason: IKPOS: Touch screen not found.

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.13.1
Version in use: 4.13.1

NSS
Expected minimum version: 3.29.5
Version in use: 3.29.5

NSSSMIME
Expected minimum version: 3.29.5
Version in use: 3.29.5

NSSSSL
Expected minimum version: 3.29.5
Version in use: 3.29.5

NSSUTIL
Expected minimum version: 3.29.5
Version in use: 3.29.5

Experimental Features
---------------------

Sandbox
-------

Content Process Sandbox Level: 1
How often is this happening? does it still happen on nightly for you? Is it reliably turning black?
Flags: needinfo?(elias4444)
Whiteboard: gfx-noted
(In reply to Mason Chang [:mchang] from comment #5)
> How often is this happening? does it still happen on nightly for you? Is it
> reliably turning black?

It's not reliable at all, though it happens a couple of times a day. I haven't tried a nightly build.
Flags: needinfo?(elias4444)
(In reply to Caspy7 from comment #2)
> I looked up drivers and it seems that that version (382.05) is from May 04,
> 2017, but there is a newer one available (382.33) May 22, 2017. (admittedly
> brand new)
> http://www.geforce.com/drivers/results/119399
> 
> Best to test that out.

I just got them installed. I'll let you know how it goes.
(In reply to elias4444 from comment #7)
> (In reply to Caspy7 from comment #2)
> > I looked up drivers and it seems that that version (382.05) is from May 04,
> > 2017, but there is a newer one available (382.33) May 22, 2017. (admittedly
> > brand new)
> > http://www.geforce.com/drivers/results/119399
> > 
> > Best to test that out.
> 
> I just got them installed. I'll let you know how it goes.

Haven't had a lot of testing time, though haven't seen the full screen black with 382.33 yet (so it's at least improved). I have however already seen the indicative full screen (even outside of the browser) black flicker when watching videos, so something is still going on.
See Also: → 1367956
I just updated my NVIDIA drivers to the latest as well. Just like the OP, I've been having this exact issue. The only time the black overlay isn't blocking access to the display is when I'm on the new tab page. Not sure why that page of all pages is safe, but the glitch happens randomly so the cause it still kind of unknown. As of this morning, I had the issue occur once when browsing a pretty static page. I updated my drivers and haven't seen it since. I'd like to assume that it's a driver conflict, but I guess we'll see. Since it happens almost randomly, it's hard to invoke the bug.

Should I upload my about:support details?
(In reply to David Anderson [:dvander] from comment #10)
> Yes, please do!

Application Basics
------------------

Name: Firefox
Version: 53.0.3
Build ID: 20170518000419
Update Channel: release
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
OS: Windows_NT 10.0
Multiprocess Windows: 1/1 (Enabled by default)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: ADB Helper
Version: 0.10.0
Enabled: true
ID: adbhelper@mozilla.org

Name: Adblock Plus
Version: 2.9
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Application Update Service Helper
Version: 2.0
Enabled: true
ID: aushelper@mozilla.org

Name: Classic Theme Restorer
Version: 1.6.6
Enabled: true
ID: ClassicThemeRestorer@ArisT2Noia4dev

Name: Flagfox
Version: 5.1.23
Enabled: true
ID: {1018e4d6-728f-4b20-ad56-37578a4de76b}

Name: Ghostery
Version: 7.2.0.25
Enabled: true
ID: firefox@ghostery.com

Name: Multi-process staged rollout
Version: 1.14
Enabled: true
ID: e10srollout@mozilla.org

Name: NoScript
Version: 5.0.4
Enabled: true
ID: {73a6fe31-595d-460b-a920-fcc0f8843232}

Name: Pocket
Version: 1.0.5
Enabled: true
ID: firefox@getpocket.com

Name: SearchPreview
Version: 8.10
Enabled: true
ID: {EF522540-89F5-46b9-B6FE-1829E2B572C6}

Name: StumbleUpon
Version: 4.21
Enabled: true
ID: {AE93811A-5C9A-4d34-8462-F7B864FC4696}

Name: Valence
Version: 0.3.7
Enabled: true
ID: fxdevtools-adapters@mozilla.org

Name: Web Compat
Version: 1.0
Enabled: true
ID: webcompat@mozilla.org

Name: React Devtools
Version: 2.1.9
Enabled: false
ID: @react-devtools

Graphics
--------

Features
Compositing: Direct3D 11
Asynchronous Pan/Zoom: wheel input enabled
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 750 Ti Direct3D11 vs_5_0 ps_5_0)
WebGL2 Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 750 Ti Direct3D11 vs_5_0 ps_5_0)
Audio Backend: wasapi
Direct2D: true
DirectWrite: true (10.0.15063.0)
GPU #1
Active: Yes
Description: NVIDIA GeForce GTX 750 Ti
Vendor ID: 0x10de
Device ID: 0x1380
Driver Version: 22.21.13.8233
Driver Date: 5-17-2017
Drivers: C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7209bde3180ef5f7\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7209bde3180ef5f7\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7209bde3180ef5f7\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7209bde3180ef5f7\nvldumdx.dll C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7209bde3180ef5f7\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7209bde3180ef5f7\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7209bde3180ef5f7\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7209bde3180ef5f7\nvldumd.dll
Subsys ID: 37533842
RAM: 2048

Diagnostics
AzureCanvasAccelerated: 0
AzureCanvasBackend: Direct2D 1.1
AzureCanvasBackend (UI Process): skia
AzureContentBackend: Direct2D 1.1
AzureContentBackend (UI Process): skia
AzureFallbackCanvasBackend (UI Process): cairo
Decision Log
D3D9_COMPOSITING:
disabled by default: Disabled by default




Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.hashstats_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 1
browser.download.importedFromSqlite: true
browser.download.useDownloadDir: false
browser.places.smartBookmarksVersion: 8
browser.search.suggest.enabled: false
browser.search.useDBForOrder: true
browser.sessionstore.upgradeBackup.latestBuildID: 20170518000419
browser.startup.homepage: https://www.yahoo.com/
browser.startup.homepage_override.buildID: 20170518000419
browser.startup.homepage_override.mstone: 53.0.3
browser.tabs.drawInTitlebar: false
browser.tabs.remote.autostart.2: true
browser.urlbar.maxRichResults: 15
browser.urlbar.userMadeSearchSuggestionsChoice: true
dom.apps.lastUpdate.buildID: 20161019084923
dom.apps.lastUpdate.mstone: 49.0.2
dom.apps.reset-permissions: true
dom.mozApps.used: true
dom.push.userAgentID: 01c20ed5129d4796bb3253b16ee39db7
extensions.lastAppVersion: 53.0.3
font.internaluseonly.changed: true
gfx.crash-guard.d3d11layers.appVersion: 52.0.2
gfx.crash-guard.d3d11layers.deviceID: 0x1380
gfx.crash-guard.d3d11layers.driverVersion: 21.21.13.7849
gfx.crash-guard.d3d11layers.feature-d2d: true
gfx.crash-guard.d3d11layers.feature-d3d11: true
gfx.crash-guard.d3d11video.appVersion: 53.0.3
gfx.crash-guard.d3d11video.deviceID: 0x1380
gfx.crash-guard.d3d11video.driverVersion: 22.21.13.8205
gfx.crash-guard.glcontext.gfx.driver-init.direct3d11-angle: true
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle: true
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-d3d11: false
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-warp: false
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-try-d3d11: true
gfx.crash-guard.status.: 2
gfx.crash-guard.status.d3d11layers: 2
gfx.crash-guard.status.d3d11video: 2
gfx.crash-guard.status.d3d9video: 2
gfx.crash-guard.status.glcontext: 2
gfx.direct3d.last_used_feature_level_idx: 0
gfx.driver-init.appVersion: 42.0
gfx.driver-init.deviceID: 0x0de2
gfx.driver-init.driverVersion: 10.18.13.5362
gfx.driver-init.feature-d2d: true
gfx.driver-init.feature-d3d11: true
gfx.driver-init.status: 2
media.benchmark.vp9.fps: 164
media.benchmark.vp9.versioncheck: 2
media.gmp-eme-adobe.abi: x86-msvc-x64
media.gmp-eme-adobe.lastUpdate: 1462711580
media.gmp-eme-adobe.version: 17
media.gmp-gmpopenh264.abi: x86-msvc-x64
media.gmp-gmpopenh264.lastUpdate: 1472127039
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20170518000419
media.gmp-manager.lastCheck: 1495817578
media.gmp-widevinecdm.abi: x86-msvc-x64
media.gmp-widevinecdm.lastUpdate: 1474745745
media.gmp-widevinecdm.version: 1.4.8.903
media.gmp.storage.version.observed: 1
media.hardware-video-decoding.failed: false
media.webrtc.debug.aec_log_dir: C:\Users\UserName\AppData\Local\Temp/
media.webrtc.debug.log_file: C:\Users\UserName\AppData\Local\Temp/WebRTC.log
media.youtube-ua.override.to: 43
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1495327820
places.history.expiration.transient_current_max_pages: 139016
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
print.printer_EPSON5E0E13_(WorkForce_545).print_bgcolor: false
print.printer_EPSON5E0E13_(WorkForce_545).print_bgimages: false
print.printer_EPSON5E0E13_(WorkForce_545).print_duplex: -437918235
print.printer_EPSON5E0E13_(WorkForce_545).print_edge_bottom: 0
print.printer_EPSON5E0E13_(WorkForce_545).print_edge_left: 0
print.printer_EPSON5E0E13_(WorkForce_545).print_edge_right: 0
print.printer_EPSON5E0E13_(WorkForce_545).print_edge_top: 0
print.printer_EPSON5E0E13_(WorkForce_545).print_evenpages: true
print.printer_EPSON5E0E13_(WorkForce_545).print_footercenter:
print.printer_EPSON5E0E13_(WorkForce_545).print_footerleft: &PT
print.printer_EPSON5E0E13_(WorkForce_545).print_footerright: &D
print.printer_EPSON5E0E13_(WorkForce_545).print_headercenter:
print.printer_EPSON5E0E13_(WorkForce_545).print_headerleft: &T
print.printer_EPSON5E0E13_(WorkForce_545).print_headerright: &U
print.printer_EPSON5E0E13_(WorkForce_545).print_in_color: true
print.printer_EPSON5E0E13_(WorkForce_545).print_margin_bottom: 0.5
print.printer_EPSON5E0E13_(WorkForce_545).print_margin_left: 0.5
print.printer_EPSON5E0E13_(WorkForce_545).print_margin_right: 0.5
print.printer_EPSON5E0E13_(WorkForce_545).print_margin_top: 0.5
print.printer_EPSON5E0E13_(WorkForce_545).print_oddpages: true
print.printer_EPSON5E0E13_(WorkForce_545).print_orientation: 0
print.printer_EPSON5E0E13_(WorkForce_545).print_page_delay: 50
print.printer_EPSON5E0E13_(WorkForce_545).print_paper_data: 1
print.printer_EPSON5E0E13_(WorkForce_545).print_paper_height: 11.00
print.printer_EPSON5E0E13_(WorkForce_545).print_paper_name:
print.printer_EPSON5E0E13_(WorkForce_545).print_paper_size_type: 0
print.printer_EPSON5E0E13_(WorkForce_545).print_paper_size_unit: 0
print.printer_EPSON5E0E13_(WorkForce_545).print_paper_width: 8.50
print.printer_EPSON5E0E13_(WorkForce_545).print_resolution: -437918235
print.printer_EPSON5E0E13_(WorkForce_545).print_reversed: false
print.printer_EPSON5E0E13_(WorkForce_545).print_scaling: 1.00
print.printer_EPSON5E0E13_(WorkForce_545).print_shrink_to_fit: true
print.printer_EPSON5E0E13_(WorkForce_545).print_to_file: false
print.printer_EPSON5E0E13_(WorkForce_545).print_unwriteable_margin_bottom: 0
print.printer_EPSON5E0E13_(WorkForce_545).print_unwriteable_margin_left: 0
print.printer_EPSON5E0E13_(WorkForce_545).print_unwriteable_margin_right: 0
print.printer_EPSON5E0E13_(WorkForce_545).print_unwriteable_margin_top: 0
privacy.cpd.offlineApps: true
privacy.cpd.siteSettings: true
privacy.donottrackheader.enabled: true
privacy.sanitize.migrateClearSavedPwdsOnExit: true
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.timeSpan: 0
security.sandbox.content.tempDirSuffix: {a9550d96-e25a-4fb2-8387-0a857f566535}
services.sync.declinedEngines: adblockplus,passwords,prefs,tabs
services.sync.engine.passwords: false
services.sync.engine.prefs: false
services.sync.engine.prefs.modified: false
services.sync.engine.tabs: false
services.sync.lastPing: 1495760499
services.sync.lastSync: Fri May 26 2017 20:06:25 GMT-0400 (Eastern Standard Time)
services.sync.numClients: 1
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1493954120
ui.osk.debug.keyboardDisplayReason: IKPOS: Touch screen not found.

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.13.1
Version in use: 4.13.1

NSS
Expected minimum version: 3.29.5
Version in use: 3.29.5

NSSSMIME
Expected minimum version: 3.29.5
Version in use: 3.29.5

NSSSSL
Expected minimum version: 3.29.5
Version in use: 3.29.5

NSSUTIL
Expected minimum version: 3.29.5
Version in use: 3.29.5

Experimental Features
---------------------

Sandbox
-------

Content Process Sandbox Level: 1
It's still happening BTW.
I'm also having this issue on Firefox 52 ESR. It started happening after the Windows 10 Creator's Update; I also have an NVIDIA card (GT 710). It happens once every couple of days while on the Guardian website, e.g. https://www.theguardian.com/politics/live/2017/may/26/general-election-2017-terror-corbyn-may-g7-sicily-politics-live

After it happens, I see in the Event Viewer a Warning: Display driver nvlddmkm stopped responding and has successfully recovered.

For most of this I had the driver version 21.21.13.7878 installed. I installed the latest one: 22.21.13.8233, but it's still happening. I see something slightly different after updating, though: previously it would go all black immediately, now parts go black before other parts and the screen flickers. I get the same Event Viewer warning.
Hmm is this a case where we blacklist a driver? I can see why the sanity test wouldn't catch this if it's happening randomly. Probably passed the sanity test and failed somewhere in the middle. Or we're not recovering properly.
Flags: needinfo?(bas)
I have been having this issue for at least 5 months, back to older version of: Windows 10, Firefox, and NVidia Drivers.

The issue survived several updates of Windows and Firefox, and two updates of NVidia driver.

It is highly random. I can be watching a video, and the web page of all tabs become black, or I could stare at a static and primitive web page and the page turns black, but I can open about:preferences and other "about" pages.

Here is my graphic info:


Features

Compositing	Direct3D 11
Asynchronous Pan/Zoom	wheel input enabled
WebGL Renderer	Google Inc. -- ANGLE (NVIDIA GeForce GTX 680 Direct3D11 vs_5_0 ps_5_0)
WebGL2 Renderer	Google Inc. -- ANGLE (NVIDIA GeForce GTX 680 Direct3D11 vs_5_0 ps_5_0)
Audio Backend	wasapi
Direct2D	true
DirectWrite	true (10.0.15063.0)

GPU #1

Active	Yes
Description	NVIDIA GeForce GTX 680
Vendor ID	0x10de
Device ID	0x1180
Driver Version	22.21.13.8233
Driver Date	5-17-2017
Drivers	C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7209bde3180ef5f7\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7209bde3180ef5f7\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7209bde3180ef5f7\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7209bde3180ef5f7\nvldumdx.dll C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7209bde3180ef5f7\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7209bde3180ef5f7\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7209bde3180ef5f7\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7209bde3180ef5f7\nvldumd.dll
Subsys ID	26823842
RAM	2048

Diagnostics

ClearType Parameters	DISPLAY1 [ Gamma: 2.2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 200 ] DISPLAY2 [ Gamma: 2.2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 ]
AzureCanvasAccelerated	0
AzureCanvasBackend	Direct2D 1.1
AzureCanvasBackend (UI Process)	skia
AzureContentBackend	Direct2D 1.1
AzureContentBackend (UI Process)	skia
AzureFallbackCanvasBackend (UI Process)	cairo
ClearType Parameters	DISPLAY1 [ Gamma: 2.2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 200 ] DISPLAY2 [ Gamma: 2.2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 ]

Decision Log

D3D9_COMPOSITING	
disabled by default: Disabled by default
I mentioned it elsewhere but forgot to mention it here (in detail). It appears that any "about" page loads up just fine without the weird eclipsing overlay. So, anything that's coming locally seems to render fine (FF's pages), but any time it's an external page, the thing just goes straight to hell. You can open a new tab, new window, etc. It won't fix until you restart the browser.
i'm confirming this bug on the basis of seeing a couple of reports about this on various support channels as well - it's impact is also sounding quite severe so i'm marking it for tracking.

all the reports i've come across so far are from users on windows 10 with nvidia graphics hardware and fairly recent drivers.
* https://support.mozilla.org/en-US/questions/1162255#answer-973872 (NVIDIA GeForce GTX 950, 22.21.13.8205)
* https://www.camp-firefox.de/forum/viewtopic.php?p=1038318#p1038318 (NVIDIA GeForce GTX 760, 22.21.13.8189)
* https://www.reddit.com/r/firefox/comments/6e0ygt/problem_with_firefox_blackwhite_screen/ (NVIDIA GeForce GT 740, 22.21.13.8233)
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Windows 10
Hardware: Unspecified → All
See Also: → 1364563
Summary: Entire browsing area for all tabs permanently turns black → Entire browsing area for all tabs permanently turns black or white (on Nvidia GPUs)
Duplicate of this bug: 1367956
Duplicate of this bug: 1368356
Tracking for 53 onwards, sounds like we need to focus testing here, communicate with nvidia and also likely blocklist the offending version of the driver...
(In reply to じゅんぺい from comment #16)
> I mentioned it elsewhere but forgot to mention it here (in detail). It
> appears that any "about" page loads up just fine without the weird eclipsing
> overlay. So, anything that's coming locally seems to render fine (FF's
> pages), but any time it's an external page, the thing just goes straight to
> hell. You can open a new tab, new window, etc. It won't fix until you
> restart the browser.

about pages are painted in a difference process, that would explain the difference.
So, this looks like bug 1163440 where people started seeing these kinds of problems with the update to Windows Creators edition (10.0.15063) which both users here report.

For people that can reproduce this - can you run dxdiag (https://support.microsoft.com/en-us/instantanswers/b319762b-f281-41b4-b746-d14de804b246/open-and-run-dxdiag-exe) and attach the results?
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1163440
Flags: needinfo?(bas)
Are there any additional messages at the bottom of the graphics tab in about:support in the session when this happens?  They're not in the reports above, but I wasn't sure if the above about:support's were from a "fresh" session that hasn't yet exhibited these issues.

Also, if you're willing (and able) to roll back from Windows Creators edition back to the version you had before, and see if the problems go away, it would help us triage this.
This might sound like a stupid question, but do you want the entire dxdiag results (exported to file) or just what shows up in the dialog window? Again, I apologize for the seemingly rhetorical question. I was able to run it, but the output is greater than what's allowed as a post. Should I just break it up into smaller posts or...?
Valid question - you should be able to click on "Add an attachment" at the top of the page, which should let you specify the whole dxdiag.txt file.
Attached file dxdiag file
As requested, I am providing the dxdiag file from my system as an attachment.
I also have this issue. I'm currently running the 64 bit version of Firefox 53.0.3 on Windows 10 Pro 64 bit (fully up to date). My GPU is an NVIDIA 780 Ti and I have the latest drivers installed. If I have hardware acceleration enabled in Firefox I get fairly frequent momentary flickers, where the Firefox window goes black for a fraction of a second before going back to normal, and I also have the issue of the window sometimes going black until I restart the browser - a few times when that happened I also got a notification from Windows saying that the display driver had stopped responding and had recovered, although that only happened maybe 3 or 4 times (so not every time the black screen issue happened). With hardware acceleration disabled it's fine.

I did not have this issue before installing the Creators Update for Windows 10. I've since done a clean install of Windows, so I'm unable to temporarily roll back and see if that fixes the issue, unfortunately. Before installing the Creators Update version of Windows I was running Firefox 52 and NVIDIA driver version 381.65 and I had no issues. With the same Firefox and driver version post-Creators Update, I had black screen issues. I've updated Firefox several times since and my graphics drivers 3 or 4 times and I've had the black screen issues every time unless I disabled hardware acceleration.
Attached file Another DxDiag.txt
I spotted this looking over my wife's shoulder on her laptop. Here's her dxdiag. She's seen it twice, and it started happening in the past month. Restarting Firefox fixed the problem.
some more reports from sumo sounding like this same issue: https://support.mozilla.org/en-US/questions/firefox?tagged=bug1163440&show=all
Attached file DxDiag.txt
Attached file About_Support.txt
QA Whiteboard: https://bugzilla.mozilla.org/show_bug.cgi?id=1342005
Track 54- as it's duplicated.
QA Whiteboard: https://bugzilla.mozilla.org/show_bug.cgi?id=1342005
See Also: 1364563
Exactly the same issue random black screen it is defo a firefox issue I returned all my new pc parts, ram, cpu, motherboard and psu and HDD's for replacement only for the issue to return. I have windows 10 creators update i5 7600 asus z270f 16gb ddr4 ram 850psu
You need to log in before you can comment on or make changes to this bug.