Crash in PostToPluginThread

RESOLVED FIXED in Firefox 55

Status

()

defect
--
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: calixte, Assigned: handyman)

Tracking

(Blocks 1 bug, {crash, regression})

55 Branch
mozilla55
Unspecified
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 fixed)

Details

(Whiteboard: [clouseau], crash signature)

Attachments

(1 attachment)

Reporter

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-72b85d41-f83c-46b3-bc62-4867e0170525.
=============================================================

There are 11 crashes (from the same installation) in nightly 55 with buildid 20170525030225. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1363290.

[1] https://hg.mozilla.org/mozilla-central/rev?node=1da418fade04a81632e3057adea1dfde1a57323d
Flags: needinfo?(davidp99)
Assignee

Updated

2 years ago
Assignee: nobody → davidp99
Flags: needinfo?(davidp99)
Cut-and-paste manual refcount bug from patches from bug 1363290.  The issue is obvious (use-after-forget).

Simple STR:

1. Go to http://www.tinywebgallery.com/en/tfu/web_demo2.php
2. Click "Add Files"
3. Choose a small image to upload.

Expected:

Plugin shows the file in the upload queue.

Actual:

CRASH!  Plugin Process crash dialog is shown.
Attachment #8871911 - Flags: review?(jmathies)
This is the #4 Windows topcrash in Nightly 20170526030203.

Updated

2 years ago
Attachment #8871911 - Flags: review?(jmathies) → review+
Assignee

Updated

2 years ago
Keywords: checkin-needed

Comment 4

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/fe7cead49195
Fix ref counting of tasks for remoted Win32 methods in plugin processes. r=jimm
Keywords: checkin-needed

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/fe7cead49195
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.