Crash in shutdownhang | FlsGetValueStub

RESOLVED WONTFIX

Status

()

defect
--
critical
RESOLVED WONTFIX
2 years ago
10 months ago

People

(Reporter: calixte, Unassigned)

Tracking

(Blocks 1 bug, {crash, regression})

55 Branch
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 wontfix, firefox56 wontfix, firefox57 ?)

Details

(Whiteboard: [clouseau], crash signature)

This bug was filed from the Socorro interface and is 
report bp-fb6e4f72-f96f-4e3b-a404-c95590170528.
=============================================================

There is 1 crash in nightly 55 with buildid 20170527030204. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1322554.

[1] https://hg.mozilla.org/mozilla-central/rev?node=7d2e74c69253e57fd7569d1e969959c5f2a36663
Flags: needinfo?(ccorcoran)
(In reply to Calixte Denizet (:calixte) from comment #0)
> There is 1 crash in nightly 55 with buildid 20170527030204. In analyzing the
> backtrace, the regression may have been introduced by patch [1] to fix bug
> 1322554.

Can you elaborate on what part of the backtrace leads to this conclusion?
Flags: needinfo?(cdenizet)
There is mismatch between the the crashing thread in the crash report and the one returned by the API.
The processed crash returned by the API [1] ([json_dump][crash_info]) is showing that thread 43 is crashing and when you look at the backtrace for this one, the function patched_BaseThreadInitThunk is in it (this is why I made the need info).
By the way, when I display all the threads in the crash report and make a grep on 'patched_BaseThreadInitThunk', there are 40 occurrences.

[1] https://crash-stats.mozilla.com/api/ProcessedCrash/?crash_id=fb6e4f72-f96f-4e3b-a404-c95590170528&datatype=processed
Flags: needinfo?(cdenizet)
After a cursory look, I don't think this bug is related. With 1322554, patched_BaseThreadInitThunk is going to show in pretty much every stack trace, which may take some getting used to.
Flags: needinfo?(ccorcoran)
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.