Closed Bug 1368437 Opened 3 years ago Closed 3 years ago

Search suggestions hint - issues on resizing the Firefox Window

Categories

(Firefox :: Search, defect, P2)

55 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 55
Tracking Status
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- verified

People

(Reporter: simona.marcu, Assigned: mak)

References

Details

(Whiteboard: [fxsearch])

Attachments

(4 files)

Attached image Hint (2).png
[Affected versions]:
- Nightly 55.0a1
 
[Affected platforms]:
- Windows 10, Ubuntu 16.04, Mac OS X 10.12
 
[Steps to reproduce]:
1. Launch Nightly with a new profile
2. Re-size the window - make it smaller
3. Focus the URL Bar
4. Open a new tab and start typing

 
[Expected result]:
- Step 3 - The search suggestions hint should be properly displayed as an animation
- Step 4 - the URL drop-down and the hint should be properly displayed
 
[Actual result]:
- Step 3 - the hint does not fit the window - please see the screencast
- Step 4 - the drop-down and the hint are not compacted enough to fit the windows size - please see the screencast
Attached image Hint+DropDown.png
Adding to triage, imo not a P1, but let's see.
Solving this and keeping the animation as expected may not be trivial. We could play with some media queries to change the expected outcome on small windows.
Whiteboard: [fxsearch]
let's name this a P2, short term I plan to check if it's easily fixable through an additional css rule.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Priority: -- → P2
it was not easily fixable at all, took a bunch of hours, but this seems to be working good enough, even if so far I only tested it on Windows (in any case I'll test on Mac before landing)
Comment on attachment 8873490 [details]
Bug 1368437 - Search suggestions hint doesn't scale well with the window size.

https://reviewboard.mozilla.org/r/144872/#review149206

Works well on macOS, too.
Attachment #8873490 - Flags: review?(past) → review+
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/d697cd9de8d3
Search suggestions hint doesn't scale well with the window size. r=past
https://hg.mozilla.org/mozilla-central/rev/d697cd9de8d3
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Attached image search hint.png
I have reproduced this bug with nightly 55.0a1 (2017-05-29) on Ubuntu 16.04(64 Bit). 

While verifying this bug i can see an issue that the search suggestions hint is cut off a little from the top. Please check attached screen shot for clarification.

Build ID   : 20170605100313

User Agent : Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0

[Bugday-20170607]
The fix works up to a certain acceptable width limit, we can't do better without sustaining development costs higher than the benefit and maintaining the required UX layout. Compared to before, now it should be possible to shrink the window a lot more, since the text wraps and the typing animation is removed.
As I said, any further step from here may be expensive and won't still fit in a few pixels window...
Verified as fixed using the latest Nightly 55.0a1 (Build ID: 20170606030207) on Windows 7 x64, Ubuntu 16.04 x64 and Mac OS X 10.12.

For the situations where the window's width is really small and the issue is still reproducible (see Comment 9), I logged bug 1370543.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.