Private window: Finite length animation is blocked for a while

RESOLVED FIXED in mozilla55

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: roxana.leitan, Assigned: tnikkel)

Tracking

55 Branch
mozilla55
x86_64
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 affected)

Details

(Whiteboard: [gfx-noted])

Attachments

(4 attachments)

Posted video iframe.mp4
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170528030206

[Affected versions]:
Nightly 55.0a1

[Affected platforms]:
Windows 10 x64

[Steps to reproduce]:
1.Launch Nightly 55.0a1 with a new profile
2.In a new private window open the attached HTML
3.Open a new tab in the window opened at step 2
4.Open a new private window and navigate to about:memory
5.Click "Minimize memory usage" button
6.Go to the tab with the animation (opened at step 2)

[Expected result]:
The animation from all frames should be displayed with without glitches.

[Actual result]:
In the second iframe, the animation is blocked for a while (please see the attached screencast)

[Note]:
The issue is intermittent and I could reproduce it only in private window.
I can reproduce in my latest Nightly.
Whiteboard: [gfx-note]
Whiteboard: [gfx-note] → [gfx-noted]
The problem is that we layerize the image, discarding an image doesn't effect the surface we use to hold the layerized image, which means it can be re-used when we go back to the page, which is okay for non-animated images, because they don't change, but this is an animated image so the frame is stale.
Posted patch patchSplinter Review
Assignee: nobody → tnikkel
Attachment #8874568 - Flags: review?(aosmond)
Attachment #8874568 - Flags: review?(aosmond) → review+
Pushed by tnikkel@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3e1dea278428
Drop the layerized version of animated images when they are discarded so we don't show an out of date version of the image. r=aosmond
https://hg.mozilla.org/mozilla-central/rev/3e1dea278428
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
I've managed to reproduce this bug on the latest Nightly 55.0a1 (Build ID: 20170608030205)on Windows 10 x64.
The issue is intermittent and sometimes, the animation from the second frame remains blocked.(please see the attached screencast)

Reopening the bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Can you please include your full steps in the video?
I tried several times but the issue is intermittent and I cannot catch it with the screen recorder.
I wasn't able to reproduce.

When you reproduce are you giving the gif enough time to finish (about 15 seconds)? In my testing the steps seem to take around 15 seconds, so if you are quick enough you can catch it before it's finished animating which would be interesting to know in which case it happens.

Probably best to file a new bug for that, it seems slightly different in that the animation seems to be stuck forever, instead of just temporarily. And we've now merged to beta, so any further fixes would be landing in a different version, that would make this bug confusing to understand.
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
ni to file the new bug
Flags: needinfo?(roxana.leitan)
Hi,

I tried several times to reproduce the bug and I reproduce it only once. I quickly switched to the tab with the iframe so the animation should not be finished.

I filed bug 1372532.
Flags: needinfo?(roxana.leitan)
You need to log in before you can comment on or make changes to this bug.