support locale switcher addons

RESOLVED INVALID

Status

()

Toolkit
WebExtensions: General
RESOLVED INVALID
9 months ago
7 months ago

People

(Reporter: mixedpuppy, Unassigned)

Tracking

(Blocks: 1 bug)

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 months ago
Without an ability to change some prefs, addons like locale switcher are not possible as a webextension.  As well, users have no ability to easily switch locales.
I think this is something we should aim to support in-product rather than as an extension API.
Flags: needinfo?(gandalf)
We will - see bug 1325870.

But if you guys want to expose mozLocaleService.getAvailableLocales and setRequestedLocales - I'm confident that the API will stay.
Flags: needinfo?(gandalf)
(Reporter)

Comment 3

9 months ago
I don't see a reason for that and nobody has asked for it.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → INVALID
I'd be willing to add setRequestedLocales if someone presents a good use case for it. But it would need a separate permission, and I'd need to be convinced there was a good use for it after we have better built-in locale selection support.

Comment 5

7 months ago
(In reply to Shane Caraveo (:mixedpuppy) from comment #3)
> I don't see a reason for that and nobody has asked for it.

I created bug 1352884 asking for that a good time ago, this bug should be a dupe of that. On the other hand, I noted this bug just now...

(In reply to Kris Maglione [:kmag] from comment #4)
> I'd be willing to add setRequestedLocales if someone presents a good use
> case for it. But it would need a separate permission, and I'd need to be
> convinced there was a good use for it after we have better built-in locale
> selection support.

I guess that further points besides that I mentioned in my bug can be only discussed after seeing that built-in support, assuming it lands not to much further after the release of Fx 57 itself...
You need to log in before you can comment on or make changes to this bug.