Stylo Build fails with 'fatal error: 'wchar.h' file not found, err: true'

RESOLVED DUPLICATE of bug 1366564

Status

()

RESOLVED DUPLICATE of bug 1366564
a year ago
a year ago

People

(Reporter: tjr, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8872753 [details]
output.txt

I'm on a mac and have a vanilla mozilla-central checkout as of:

> changeset:   402171:39d5cc0fda5e
> fxtree:      central
> parent:      402170:ae492e161967
> parent:      402126:c3a2ed2ce954
> user:        Ryan VanderMeulen <ryanvm@gmail.com>
> date:        Tue May 30 12:39:46 2017 -0400
> summary:     Merge inbound to m-c. a=merge

My mozconfig is

> ac_add_options --enable-stylo
> export LLVM_CONFIG=/Users/tritter/.mozbuild/clang/bin/llvm-config

The build fails with

> 0:15.37 /Users/tritter/.mozbuild/clang/include/c++/v1/wchar.h:119:15: fatal error: 'wchar.h' file not found, err: true
> 0:15.37 /Users/tritter/.mozbuild/clang/include/c++/v1/stdlib.h:94:15: fatal error: 'stdlib.h' file not found, err: true
 
The complete build output is attached (this is the second ./mach build, so there's some things skipped that presumably built fine the first time.)
If you run `xcode-select --install`, does this fix the issue?  If so, this is a dupe of bug 1366564.
Flags: needinfo?(tom)
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(tom)
Resolution: --- → DUPLICATE
Duplicate of bug: 1366564
Blocks: 1375774
No longer blocks: 1356991
You need to log in before you can comment on or make changes to this bug.