Download Manager javascript errors

VERIFIED DUPLICATE of bug 132331

Status

--
trivial
VERIFIED DUPLICATE of bug 132331
17 years ago
14 years ago

People

(Reporter: smaug, Assigned: bugzilla)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020410
BuildID:    2002041003

Sometimes I get the following error:
Error: [Exception... "Component returned failure code: 0x80520012
(NS_ERROR_FILE_NOT_FOUND) [nsILocalFile.isExecutable]"  nsresult: "0x80520012
(NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
chrome://communicator/content/downloadmanager/downloadmanager.js ::
dVC_isCommandEnabled :: line 138"  data: no]
Source File: chrome://communicator/content/downloadmanager/downloadmanager.js
Line: 138

The fix is trivial:
Change the downloadmanager.js line 137 to
    case "cmd_openfile":
      try{
        if (!isDownloading && getFileForItem(selectedItem).isExecutable())
          return false;
      }catch(ex) {return false;}

Reproducible: Always
Steps to Reproduce:
1. Download an executable and the remove it from harddisk but
not in downloadmanager.

Comment 1

17 years ago
Marking as dupe of bug 132331. Reporter: If you disagree, please reopen this bug.

*** This bug has been marked as a duplicate of 132331 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.