Update cubeb from upstream to 3428c2b

RESOLVED FIXED in Firefox 55

Status

()

defect
P1
normal
Rank:
15
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: achronop, Assigned: achronop)

Tracking

unspecified
mozilla55
x86_64
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox54 wontfix, firefox55 fixed)

Details

Attachments

(1 attachment)

Pick commit:

3428c2b Alex Chronopoulos       audiounit: remove stream lock from property listener and get position
Assignee

Updated

2 years ago
Assignee: nobody → achronop
Blocks: 1335512
Rank: 15
OS: Unspecified → Mac OS X
Priority: -- → P1
Hardware: Unspecified → x86_64

Comment 2

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/cda03201b522
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Assignee

Comment 3

2 years ago
Approval Request Comment
[Feature/Bug causing the regression]: This cubeb commit which solves Bug 1335512
[User impact if declined]: Video playback stop working after a while when plug/unplug external headset
[Is this code covered by automated tests?]:No
[Has the fix been verified in Nightly?]: It is landed in m-c yesterday (2017-05-31)
[Needs manual test from QE? If yes, steps to reproduce]: It's hard to repro reported noticed the issue once per 2 week use and only when system was under load.
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: It's not risky patch, small fix ~3 lines which make sure that a specific notification callback cannot be blocked by audio stream mutex. 
[Why is the change risky/not risky?]:not risky
[String changes made/needed]:N/A
Attachment #8873357 - Flags: review?(kinetik)
Attachment #8873357 - Flags: approval-mozilla-beta?
could we get confirmation that this does fix the bug reported in many places?

I haven't seen any confirmations that it does fix it from anyone who had the issues.
Comment on attachment 8873357 [details] [diff] [review]
Bug 1368910 - Uplift cubeb commit 3428c2b.

Review of attachment 8873357 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, but would be good to get confirmation of the fix before uplifting.
Attachment #8873357 - Flags: review?(kinetik) → review+
Assignee

Comment 6

2 years ago
The issue is hard to repro and we running to get it to beta before the code freeze. The fix is certainly good and solves a deadlock case very similar the one described here. I am in communication with the reporter who told me that will reopen the initial issue (bug 1335512) in case he has it again. In any case we want that to beta.
Comment on attachment 8873357 [details] [diff] [review]
Bug 1368910 - Uplift cubeb commit 3428c2b.

While this maybe a good thing, I would prefer to let this ride the 55 train due to the following reasons: 1) this fix hasn't baked enough in nightly and we are unaware of fallouts. 2) If this turns out to be a big problem on release54 (don't think that's the case from release53, beta54), we can consider including this as a fix in a dot release, 3) need the bug opener to confirm this fixes the bug.
Attachment #8873357 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
Ritu, I think you should reconsider the severity of the problem.

It renders any video playback (including YouTube) inoperable. Requiring to exit Firefox and restart.

We've had dozen of bug reports on the matter, which likely indicates thousands of people affected.
You need to log in before you can comment on or make changes to this bug.