Closed Bug 1369061 Opened 3 years ago Closed 3 years ago

Add Solaris atomic.h to system-headers

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox55 fixed)

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: petr.sumbera, Assigned: petr.sumbera)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; SunOS i86pc; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20170509094433

Steps to reproduce:

While linking libxul on Solaris I got:

 5:29.92 Undefined                   first referenced
 5:29.92  symbol                         in file
 5:29.92 membar_consumer                     ../../gfx/layers/Unified_cpp_gfx_layers8.o  (symbol scope specifies local binding)
 5:29.92 membar_producer                     ../components/protobuf/Unified_cpp_components_protobuf1.o  (symbol scope specifies local binding)
 5:29.92 atomic_cas_64                       ../components/protobuf/Unified_cpp_components_protobuf1.o  (symbol scope specifies local binding)

The reason is that config/gcc_hidden.h is included and atomic.h which is used in toolkit/components/protobuf/src/google/protobuf/stubs/atomicops_internals_solaris.h doesn't have its counterpart in system_wrappers/ to change GCC visibility to default.
Attached patch Bug1369061.patchSplinter Review
Attachment #8873021 - Flags: review?(mh+mozilla)
Component: Untriaged → Build Config
Product: Firefox → Core
Comment on attachment 8873021 [details] [diff] [review]
Bug1369061.patch

Review of attachment 8873021 [details] [diff] [review]:
-----------------------------------------------------------------

Hopefully this shouldn't impact local atomic.h includes from media/ffvpx/libavutil in a meaningful way.
Attachment #8873021 - Flags: review?(mh+mozilla) → review+
Keywords: checkin-needed
Assignee: nobody → petr.sumbera
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/da6426dca379
Add Solaris atomic.h to system-headers. r=glandium
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/da6426dca379
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.