Browser toolbar visible in custom tab (while loading)

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
9 months ago
6 months ago

People

(Reporter: sebastian, Unassigned)

Tracking

(Blocks: 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

STR:
* Open browser and load a website
* Press Home
* Open third-party app and load a custom tab

Expected:
  Only custom tab UI should be visible

Actual:
  Browser toolbar is visible (in web content?) while website is loading

Device:
  Google Pixel XL (Android 7.1.2)
Created attachment 8873105 [details]
Screenshot_20170531-185722.png
A similar bug was fixed in bug 1358805.
See Also: → bug 1358805
Does this happen every time for you? I tried to reproduce with out success in Nightly. I saw other issues such as trying to open the custom tab in Firefox just kicking me back to the custom tab the first time but could never get the static toolbar snapshot to show up.
Flags: needinfo?(s.kaspari)
It doesn't happen every time - but often enough to be noticeable and confusing while normal usage. Note that this only happens while the website is loading and doesn't paint anything yet (I guess). I assume it is more likely if the page is loading slowly. I thought it's more likely to happen while the page in Fennec is loading too - but this doesn't seem to be the case after some more testing.
Flags: needinfo?(s.kaspari)
I'd like to wait until the geckoview version has landed. I'm hoping this will fix the issue since the custom tabs should get their own toolbar animator which will be in a known state instead of inheriting Fennec's.
I haven't seen this at all since we're using GeckoView.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.